Trouble with AUTO mode

Hi everyone

I´m working with a Skywalker X-5 model and I have problems using the Auto mode in APM.

I have tried FBWA and Manual and both works well, but when I use Auto here comes the problem.
When I give the plane some waypoints I suppose that I have to start with a TakeOff if I want to start the flight from the ground. The thing is that when the first point after the HOME one is a TakeOff it appears this message:

Executing nav command ID #22
Timer interrupted AUTO

That second message blocks everything and the motor doesn´t spin.
If I plan a mission without a TakeOff point that message doesn´t appear, but the motor doesn´t spin neither.

If someone has an idea of what is happening I would be glad to read it.

can you provide a link to a log?
Also, what takeoff method do you want to use? The timer interrupted implies you are doing a conditional takeoff, such as waiting for GPS speed, or acceleration, or a timer.
See this page for detailed instructions:

Hi @tridge

I managed to solve it. I do all the calibrations indoors and because of that the GPS wasn´t able to pick any satellites so when I tried the AUTO mode the message of “Timer interrupted” always appeared.

Thanks for the help

@tridge The timer interrupted fires for me if I ever restart the mission/do multiple takeoffs or abort then restart a takeoff. I have no conditions set, but it will always come back the second time. It’s actually a really weird message to send to the GCS I think. (at lest in the case where the timers/conditions are all disabled)

Hi! Can you please :pray::pray: explain in a little bit more detail how you solved the “Timer Interrupted AUTO” problem? Do you know what causes this? I didn’t use my fixed wing aircraft for a while, it was working perfectly before and now I get this message and can’t find a way how to solve it. It’s so strange.

Thank you!

Hello. I am having the same issues and I cant take off using AutoTakeOff feature. Did you manage to solve it? Thank you.

Perhaps follow this advice?