Servers by jDrones

Trouble changing "home" position

I am having trouble writing a new “home” position to ArduRover 3.4.1

I can change the home position in Flight Planner but the coordinates do not make it into the pixhawk (when I read the pixhawk waypoints it always shows the position that the pixhawk first received GPS lock).

What am I doing wrong here?

if im not wrong it should set home position after you hit the safety switch.

1 Like

Yes, like @Michael_Silke says, the home position is set when the vehicle arms.

It’s also possible to set the home position specifically (and once this is done it won’t change even if the vehicle is armed or disarmed) but the Mission Planner’s interface is confusing to me at least so I’ve raised an issue for the Mission Planner here.

I see two things you could try:

  • open the Flight Data screen and right-mouse-button click on the map and select “Set Home Here” >> “Set Home Here”.
  • open the Flight Plan screen and right-mouse-button click on the map and select, “Set Home Here”.

I don’t know if either of these work. Perhaps @meee1 knows.

Hello All

I have been having issues with this also. I have tried setting home from both flight plan and flight data screens, the home position moves, but when i write to pixhawk it does not update.
If you then read from the Pixhawk the home location bounces back to startup/boot position.

Simply dragging home position does not seem to work as well.

I did manage to move it once, but have no idea what combo of read/write and screen made it work. I have not been able to replicate it since.

I would defiantly say that setting a different home location in mission planner does not preform as expected. I am using latest rover in boat frame.

rmackay9, thanks for raising the issue on GitHub.

My experience is about the same as Erl77’s. I have tried to to right-mouse-click the flight data screen “Set Home Here” >> “Set EKF Origin Here” but it does not change the “home” position. Something is keeping the home position from being written to the pixhawk from mission planner.

I suppose that since it’s a boat, we can just reboot (Ctl-F) the pixhawk at the position needed for “home” but that’s a bit clunky.

A parameter to toggle where home is set from would be helpful.

@KG_Fairbarn, @Erl77,

It’s really a Mission Planner issue I’m afraid. the ArduPilot software in the vehicle is handling the setting of home properly as far as I know. It’s the user interface that is difficult. Hopefully @meee1 can resolve this issue.

It is long time ago. But I still experience same issue.
The home position is set where reboot or restart vehicle

Servers by jDrones