Tricopter rolling ass

Hi, I know that this question has already been asked and I read lot of things about that. I also experimented a lot, but never succeeded on resolving this issue. My tricoter slowly dances from the ass. Well at least it flies and I can even do some figures but it constantly yaw back and forth slowly as soon as I’m not doing hard maneuvers. This is not violent movements and it does nots prevent from flying, but I would really like so solve that. Does any Tricopters pilots has already had some kind of problems and how did they approach it to troubleshot.
Example from last flight (Accro) :


PIDs and so on :
I also added Dynamic Notch fitering on Gyro and Static Notch on Accs :
and last but not least, vibe analysis from last fligh :
Well that said, I have also to say that I’m a beginner in PID tuning so any kind of help would be very much appreciated
Thanks
Frame picture for reference, props are 7 inch : image

1 Like

Are the ESC’s calibrated? Is your servo straight?

Yes, ESCs calibrated and Servo well straight.

Have you tried autotune for the yaw axis?

1 Like

Well autotune is on my roadmap to solve this but I didn’t did it till now because I thought it was only to optimise assisted modes. As my problem occurs also in Accro I was not sure it could help. Maybe I’m wrong.

1 Like

Autotune stabilizes all modes because the “stabilization” makes the copter respond how you want it to works even in acro, so it’s just stabilization that makes sure that the stick values are corresponding with the actual copter angle/attitude. So try autotune, maybe it will help, and then fine-tune manually!

1 Like

You can also set AUTOTUNE_AXES to 4 so it only affects YAW, but I would recommend setting it to 7 (all)

Incorrect. Whether it will fix your servo yaw stability problem or not is TBD.

Ok Thanks for this advice. I will try to do it today and let you know if it changes anything. Just one more question : is it better to disable notch filtering (static & dynamic) before doing Autotune ?

I don’t know what is Notch filtering so I can’t answer this question

Well another question then :wink: Is it a problem if there is some wind during Autotune and what is the best mode do do it (PosHold, AltHod, etc.) ?

Ideally you want no wind at all, but a little wind is ok, but I would wait for a very calm day.

The best mode to do it in is althold, also takeoff in althold if possible.
I’m yaros1 from another account

Your order of actions would be:

  1. Switch to althold

  2. Takeoff to at least 10 meters

  3. Turn on autotune

  4. If the copter approaches obstacles you can move it, but do it in an open area so you don’t need to move it all the time, so it can do it fast enough before you run out of battery.

  5. After the copter stopped twitching, try to move it and see if something changed, if you like the changes DON’T turn off autotune, land and disarm with the autotune switch in the ON position.

  • If you think that the copter became less controllable, turn off autotune before landing.

Thanks a lot for these tips. I will then way to do it because it is very windy today here. With my other drones using Arducopter, I always turned off autotune mode after hearing a long bit…as described in documentation. Hope it is good too :slight_smile:
If I can only give you an advice in return it would be to read that about notch filtering : https://ardupilot.org/copter/docs/common-imu-notch-filtering.html It changed drastically my tricopter behavior in a good way. Maybe it can be useful for you too.

If you disarm with the switch in the off position, the pids will not save, also take a screenshot of your current PID values just in case!

You might find auto trim useful too!
Watch this video, it explains both autotrim and autotune very good!

No, it’s important to have the Notch filters active for Auto Tune. Also, you stated above that you are using the Static Notch filter for the accels. Neither the Dynamic or Static notch filter is active on the accelerometers only the Gyros. If the Dynamic Notch filter is configured properly the Static Notch filter is typically not needed. If the cutoff frequency is set too low it can negatively effect control.

Yeah, you’re probably totally right. In fact when I added static notch filtering in addition to dynamic one, I noticed a strange negative impact in flying. I did it due to this in the documentation :

As I did just one flight since I added it, I couldn’t conclude that it comes from that, but that is very probable. I will confirm that as soon as wind will calm down here.
Regarding Accelerometer, thanks for the information. Well, I did that assumption because I though that something good to filter vibrations on gyros could be good also for Accels.

Post a link to the pre-filter flight log you used to configure the Dynamic Notch filter if you like.

I used that :


and configured like this :
I used Throttle based setup mode as I don’t have RPM sensors nor BLHeli telemetry

Then Post Flight Analysis I was like that :