Toilet bowl on first flight of the day


I have a very strange issue with my quad running pixhawk 2.1 AC 3.5.5

During the first take off of the day I have a sort of Toilet bowl for the first 15-20 sec of flight (loiter mode) than everything came back to “normal” with rock solid GPS position.

Alternatively If i land, disarm, arm and fly again (always loiter mode), No problem at all.

I tried to switch to alt hold mode and quad is very stable, so is a GPS/ mag issue.

M8n gps with 15-18 sats and HDOP 0.8-0.6.

Already tried to enable automatic compass offset but nothing. Of course compass is calibrated together with compass/mot.

Please tell me if you need some more info.

Toilet bowling is an indication of a compass issue.
There may be other causes but 9 out of 10 times its compass.

Just because you have calibrated the compass does not mean it’s happy from that point on.
One of the reasons we don’t use auto takeoff a lot in the field is to watch the copter in loiter for a few seconds to make sure the compass is happy.
If any toilet bowling is seen, the copter is landed and the compass is recalibrated.
Where you had calibrated the compass could have an effect.
Where you are flying could have an effect.

Do a live calibration where you are flying and see if that helps.

If using multiple compasses make sure they are all aligned exactly in the same direction and not a ‘few’ degrees out.