Compass/Motor calibration Copter 3.2.1 with APM2.8

Hello All,

I have a 450 size elektro heli with Flybar stabilisation.
There’s an APM2.8 installed with Copter 3.2.1 and an external GPS/Compass.
Everything is working so far, but I was testing in loiter mode and it was “Toilet Boiling” heavily.
After some search on the internet I fount that I forgot to do the Motor/Compass calibration.
But when I start the Motor/Compass calibration, I’m not able to run the motor.

To test, I disabled all the pre-arm checks but still nothing.
(In stabilise/loiter/althold mode I can arm and fly the heli)

Does anyone have some tips where to look at to get the motor running in calibration mode?

hi @Dekkertje
do you connected battery ? because motors cant be start with USB power


you should use a telemetry instead of using USB cable directly
also send log file for analysis

Really? I’m pretty sure that I did that, doesn’t ESC calibration work that way?

what is your config?
for example with simonk ESCs you cant calibrate them without connecting battery

I’m not sure right now, but I’m pretty sure that I had USB and battery connected at the same time more than once, but I guess you never stop learning…

When I had several of those old APM Flight Controllers flying I connected the battery and USB routinely with no problem. The warning is if everything is at Absolute Max which is unlikely to happen.

in addition to @dkemxr post

Hey everyone,
Yes, I have connected the battery. I tried to run the heli, in stabilization mode, that works. Then I tried to perform the compass / motor calibration that didn’t work. I use a telemetry module to connect to the heli, it is safer than a USB cable when the heli is active.

All help is greatly appreciated.

2019-10-10 20-48-18.bin (416.6 KB)

I did another test today and it is still not working.
Test was again:

  • Stabilize mode, arm, throttle up, (No Flight), disarm.
  • Start calibration mode, no throttle, because it is not running, I don’t know the reason.
    Log is attached (Date is wrong, again, don’t know why)
    2019-09-27 21-04-55.bin (66 KB)

I have never found Motor/Compass calibration useful and in one case it caused yaw drift. Perhaps it’s another problem. One thing you could surely do is replace the APM FC with one that supports the current Trade Heli stable version. Among other things support for APM is waning because few are using them any longer so finding someone with knowledge is increasingly more difficult.

i agree with Dave too, i never used Motor/Compass calibration and all of my copters are flying good in loiter.
unfortunately there is no useful data in your log maybe you should check your log bitmask for your logging problem

but i think this post could be useful

I found that the Heli was not perfectly balanced in terms of weight distribution, after solving that it’s flying better. But I still didn’t find out why the motor compass calibration isn’t starting. Any tips to check to get it working?