Tmotor U8 Pro not spinning up at 10% in motor test

so i have 4 tmotor u8 pro motors on flame 80a esc’s when i run my motor test in ardupilot motor C will not spin up at 10% throttle every other one will. I have to crank motor c to around 25% before it starts up. I have tried recalibrating the esc’s over and over again but its the same issue. weird thing is when i bench tested all these parts this was not an issue.

Swap ESCs around to see if the issue follows an ESC

the issue follows the ESC… they were brand new ESC’s its acting like this one ESC is not accepting maximum and minimum throttle settings.

Set these and test again:
and this, bit it’s only important once airborne
MOT_THST_EXPO,0.2 (or up to 0.4)

If that ESC is still giving you trouble it will need a replacement.

T-Motor Flame ESC’s

Flame out

1 Like

yeah I tried all that, guess I’m replacing it ugh lol

Go grab yourself some APD esc’s, been testing them to the limits and a 120amp esc is really a 200amp continuous esc.

1 Like