Servers by jDrones

Tiltrotor support for plane #2


(Greg Covey) #41

Parfenov,

It looks like you are using SERVO11 for Left Motor Tilt (75) and SERVO12 for Right Motor Tilt (76). Each SERVO output has these settings:

SERVO11_FUNCTION,75
SERVO11_MAX,2200
SERVO11_MIN,600
SERVO11_REVERSED,0
SERVO11_TRIM,1500
SERVO12_FUNCTION,76
SERVO12_MAX,2200
SERVO12_MIN,550
SERVO12_REVERSED,1
SERVO12_TRIM,1500

You can change the til from up to down by changing the flight mode from QSTABILIZE to FBWA. This can be done via the R/C transmitter or from the Mission Planner Actions tab and MODE button.

If the servo goes in the wrong direction, change REVERSED from 0 to 1 or from 1 to 0. Does this makes sense?


(Parfenov Razvan) #42

Now i understand… Look at this thrust vectoring. It’s ok ? it not to lazy if i can say that ?:))


(Greg Covey) #43

It is hard to say. You probably need to try it in a hover.


(Parfenov Razvan) #44

i understand. I’m so happy because the tilt servo is set, everything is normal, the transition is very good but the last problem is with the rear motor. It doesn’t want to work… only 1 second after arming… I checked servo function and it’s ok… i don’t know where is the problem… i tested in qstabilize…

Edit: i tested outside, and the rear motor start only when he want… and when I’m changing to fbwa he stops immediately and when I’m changing to qstabilize it doesn’t start, very strange …


(Greg Covey) #45

I think you may have the wrong setting for SERVO7. If your rear motor is plugged into OUTPUT7, change the SERVO7_FUNCTION from 39 to 36. Alternatively, you can plug the rear motor ESC into OUTPUT8 which is already set for FUNCTION 36.

What output is your rear motor ESC plugged into?


(Parfenov Razvan) #46

into output8… 7 is clear

i changed to output 7 and set to 36 but is the same behavior… it start and stop after 1 second


(Greg Covey) #47

I am running out of ideas. Is the ESC the same type for all three motors? Has it been calibrated like the front ESCs?

I use Q_ESC_CAL=2 from the procedure here. To power up your Pixhawk without powering the ESCs, use the USB port to connect to Mission Planner. Then use your battery to power the ESCs in Step 7.


(Parfenov Razvan) #48

I don’t know how to thank you Greg. The problem was to the ESC and not to the pixhawk… I have set it and everything works normal. All motors respond and, the transition is ok, the 3rd motor start after i’m switching to qstabilize. Thank you very much… in next days i’ll try to fly it.


(Greg Covey) #49

Awesome news! Good luck on your flight!


(James Stewart) #50

I had a weird thing happen with my tilting quadplane yesterday, I thought I’d ask here.
I was flying an AUTO mission, including takeoff and landing.
-The wind was minimal
-I DO have weathervaning enabled
-I started the takeoff pointed into the wind
-I DO have leveltransition enabled.
The quadplane made it to the takeoff height okay, but exhibited unexpected behavior during the transition. In short, as soon as the transition began, and before it had any airspeed, it yawed about 90deg to the right and started flying towards the first waypoint immediately.
I’ve flown a couple of AUTO missions at this point, but it’s the first time I’ve seen it do that. I’d expect it to transition while facing INTO the wind, then turn after a set distance. At least, that’s what I want it to do. Is there any parameter I can set to achieve this?
Thanks,
-James


(Casey Welton) #51

Hi everyone,
I am working on a fixed wing tiltrotor tricopter for my undergrad in aerospace engineering. We are currently set up with:

  • Pixhawk
  • 2x 5000 mAh batteries (Powers motors and motor tilt servos)
  • 1x 3000 mAh battery (reciever/control surface servo battery)
  • Lumenier 50A 4in1 ESC (DSHOT enabled)
  • X8R receiver running SBUS
  • Taranis X9D transmitter

We are running into problems after arming the motors and the pixhawk where the motors will turn on but after so long of running completely stop. It seems that it resets the flight controller as well. Has anyone else experienced this problem? I have been following all of the Tiltrotor support and Nimbus VTOL support but I’m not sure I’ve seen a problem related to this. If anyone has any suggestions I would greatly appreciate the feedback.

Firefly_04_07_19.param (17.0 KB)


(Wasim Akram) #52

Hi Casey,
How is the pixhawk powered?


(Greg Covey) #53

Casey,

I can’t see an image of your plane, and the video says it is not available, so this is just a guess. I think that your Q_FRAME_TYPE setting is incorrect. You should be set it to 1 not 2.

Can you post an image of your project? How about a .bin log?


(Parfenov Razvan) #54

Greg, I’m trying to set up a failsafe for my VTOL but only documentation is for quad and plane. I don’t know how to set up after losing of RC signal to enter to remain in qstabilize and decrease the throttle. Can you help me? now if I’m turning off the radio the plane enter in manual mode, turning my tilt servo to 90 degrees and remain at the same rpm.


(Parfenov Razvan) #55

And another big problem is with compass… I don’t know what to do more to be ok. I have a error, bad compass variance… I calibrated few times and after few movements the error start again. I tried to fly today and it start to turn on yaw.


(Greg Covey) #56

Parfenov,

For compass, make sure that only the one external compass with the GPS is activated. Do the on-board calibration and verify that North/South/East and West look reasonable in the Mission Planner HUD. When powering up the Plane or VTOL, do it from the spot of take-off or move it forward to that spot. Alternatively, you can always do the reset from the Mission Planner Actions tab. Planes don’t like moving sideways or backward.

For Radio Failsafe in Plane, you need to first program your radio receiver to set a low PWM when the transmitter signal is lost. This actives RTL mode when the long failsafe timeout is reached (FS_LONG_TIMEOUT) but you also have to enable FS_LONG_ACTN. For VTOLs, you want to also enable QRTL so it transitions to hover before landing. The Wiki has more information on failsafe modes here. Since you are seeing the plane enter MANUAL mode, I suspect that you need to program your receiver failsafe setting.

Good luck!


(Casey Welton) #57

Hey Aeroakram,
I am powering the pixhawk FMU using a 3000 mAh battery connected to the common power module that comes with the pixhawk. Soldered to one end of the power module is a 10A BEC which is connected the receiver. I don’t have the opposite side of the power module plugged into anything because that would normally be plugged into a PCB. Powering my motors and tilt servos is 2 5S 5000 mAh batteries. These are connected to my 4in1 50A ESC and I have my 20 A CC pro BEC soldered from the connector that plugs into the ESC to the pixhawk. This BEC has two servo output connector ends that I have plugged into the pixhawk SBUS rail.


(Greg Covey) #58

Casey,

From home, I can now see your image (work locks out lots of stuff) but your video is still unavailable. From looking at the image and your .param file, I can see many issues.

The SERVO9_FUNCTION,33 seems correctly labeled as Motor1.
The SERVO10_FUNCTION,36 is correct but your image says Motor2 instead of Motor4.
The SERVO11_FUNCTION,34 is correct but your image says Motor4 instead of Motor2.
The SERVO14_FUNCTION,75 should be doing the left motor tilt but you have it on the right tilt servo.

All this affects the Q_TILT_MASK parameter…and so on.

You can set it up any way you want but I would recommend following the setup in the image below. In this manner, the Nimbus 1800 VTOL setting will be much closer, if not exact.


(Casey Welton) #59

Hi Greg!
Thanks for the advice. I did see this in the Nimbus Tricopter VTOL thread, although since I am running DSHOT on my ESC, I have my motors set up to SERVOS9/10/11 and my servo tilt mechanisms would be SERVOS 12/13/14 however I noticed that the tilt mechanism wasn’t responding to SERVO12 pin so I believe that to be a dead pin. In this case, I mapped my right/left tilting mechanisms to 13/14 and my rear tilting mechanism I put on SERVO7 and set as a tilting motor. In this case I’m unsure if the Q_FRAME_TYPE is 1 or 2 because the back motor is pointed down in vertical take off and points backwards during horizontal flight. Also I fixed the video to be public and I’m working right now on figuring out how the logs work. One more thing, when changed my Q_MAV_TYPE to VTOL tiltrotor, the description and options disappear. Any ideas on how to fix that?


(Parfenov Razvan) #60

Greg, i’m sorry that i’m asking you so many times for my problem. I tried to set up correctly the compass but no success. Or I don’t know how to set up the external compass from GPS or something is not ok. Another problem is when i’m trying to take off it makes a drift turn. It doesn’t want to stay stable in direction, i don’t know if this problem is from the compass.