Thrust loss problem and MOT_THST_EXPO adjustment


I was out flying and experienced “thrust loss” messages, and “landed” pretty hard in a pile of sand… :stuck_out_tongue:

I’m using a durandal H7 on copter 4.0.3.

Can someone with some idea about thrust loss take a look at this log?

I just had a quick look, and it seems like there is a loss of voltage? And its wierd that motor 1 (front right - rcou.c9) and motor 2 (back left - rcou.c10) are running so much slower than motor 3 (front left - rcou.c11) and 4 (back right - rcou.c12)…

Before i tried to fly i followed the tuning process and measured the thrust curve of the motor, and read this mot_thst_expo thread

I adjusted the MOT_THST_EXPO, MOT_SPIN_MIN/MAX/ARM accordingly, but it looked rather wierd…, but i changed them anyway. Following is a screenshot of the calculations (from a spreadsheet in the docs somewhere), and the log file. The current was not used in the calculations, so i did not include them (the values shown are NOT from these measures)

Okey, so my first take on adjusting MOT_THST_EXPO was faulty as i forgot to measure current:)

Motor: t-motor mn3508, kv380
props: 15x5,5" CF

I built myself a thrust stand and logged the parameters at different PWM values.

Here are the results plotted in the same spreadsheet as above, dropbox link:
thrust results

So my question is, what is the MOT_THST_EXPO parameter supposed to be set to? It says to minimize the difference, but the parameter is very low then? And in the docs it it shown to be around 0.6 for this size of props


It can depend on what ESC you are using too.
Use the value from the tuning instructions and the helper spreadsheet unless you KNOW you’ve got an ESC that linearizes the thrust.

Also there’s the ALT A key combination in MissionPlanner.

thanks for the reply, i will take a look at the spreadsheet. I followed the tuning instructions for arducopter, as i linked to in the 1st post.

The esc is a flywoo INI 45A BL_heli32 link to esc (

I don’t know if it linearizes the thrust?


I’m sure they do not.

@Leonardthall im sorry to bother you, but reading this thread i think you know how this parameter work…:slight_smile:

Could you please have a look at the Ardupilot_thrust_fit.xls sheet with my data that i gathered from the test bench (link in 2nd post)? I dont quite understand how im supposted to “best fit” the curve. I tried, but the mot_thst_expo get quite low?

Just use the default value for that size prop: MOT_THST_EXPO,0.71

yeah, that’s about were it is atm.

I ran the alt+a key in MP and it was about the same as i had initially. I’m a bit unsure about the “airscrew size”, but assumed it was the prop size?

It feels responsive after i did a autotune, but now when i am hovering i have a little oscillation i have to figure out? I read this post AltHold Up/down oscilation, so will try that. I saw something that looked like “noise” in the logfile