Servers by jDrones

Throttle speed too high in Acro and steering Modes

pixhawk2
(Rick Bonari) #1

I have a Traxxas Rustler set up as a Rover. I have a pixhawk 2.1 with taranis receiver and transmitter. I have the Here2 GPS with mRobotics Telemetry. Everything is working and modes are all setup correctly. Everything works as expected in manual mode. I have the throttle on the right transmitter stick and steering on the left stick. The throttle is center stop with throttle stick up goes in forward and down the vehicle goes in reverse. One of the issues that I had was that the Traxxas Rustler vehicle would go too fast. I was able to use the transmitter to reduce the max speed. In manual this works perfectly when vehicle is armed. When armed in manual mode and I switch to Acro or Steering modes the throttle speed is too fast. It is like it doesn’t follow the lower max throttle setting on the transmitter. Also the second I switch to Acro or Steering modes the vehicle starts moving very fast. I tried setting MOT_THRTL_MAX to 50 percent with no change in max speed and I set cruise speed and throttle using switch on channel seven to capture cruise speed and throttle. That worked and gave me a voice prompt. Not sure what to try next after searching the forums on the internet, etc. The other problem in Acro and Steering modes is that the steering is very intermittent and oscillates. Again steering works fine when armed in manual. Any help on this would be much appreciated. Thanks much for the help !!! Rick

(David Boulanger) #2

Can you post a .bin log?

(Rick Bonari) #3

Yes, I am brand new to the forum and I need to understand the BIN and TLOG files so I will try and attach it to another reply. I can verify I am correctly switching from manual to acro modes by monitoring the flight display in mission planner. Doesn’t seem like when you first switch to acro and steering modes the vehicle starts moving at high speed. I’m trying to start calibrating the speed/throttle and steering controllers before moving on to the final navigation controller calibration. Can’t do anything the way the vehicle is behaving. Will send the log file and any further ideas are much appreciated…Rick

(Rick Bonari) #4

Once I have the log file how do I attach it to the post? It is not readily apparent…Rick

(Manu Pillai) #5


Try 7th icon from the left to upload log files. Same procedure to upload a picture

(Rick Bonari) #6

I downloaded the datafash files successfully using mission planner but when I do an auto analysis in mission planner to look at the data I get the following error: "failed to download log analyzer - bad input file. No matter what file I download (bin or log) I get this error? Any help on this issue is much appreciated. I will give it a go and try to send the bin files. I think I got it now. It was the one icon I didn’t try. Still need help on why I get the log analyzer load failures. It should be noted that I haven’t been able to do anything with the vehicle yet in mission planner as I start Acro Mode and the vehicle goes to max throttle. This throttle speed is way to fast to do anything. Please see my first post. Because of this I’m not sure what good the bin log file is going to be. My main issue is how do I get the throttle speed lower and acro and steering modes. Thanks much…Rick

(Rick Bonari) #8

I tried uploading the compressed bin file and it quit at about 60 percent. what is up with this? Thanks much…Rick

(Manu Pillai) #9

Upload it elsewhere (Google drive or dropbox) and send a link here.

(David Boulanger) #10

Maybe a parameter list while you are figure out how to load a .bin. Sounds like a simple parameter issue.

(Rick Bonari) #11

I have already looked at the parameter lists and haven’t found anything obvious. Do you have an idea on a parameter I might be missing? Also why do I get the log analysis - bad file error when trying to do a log analysis in mission planner. The files downloaded successfully? Rick

(David Boulanger) #12

I don’t know why you are getting a bad file error. For the most part you should not have to make adjustments in your transmitter. I’m curious of your radio calibration and you SERVO_X stuff. if manual works fine but Acro and Steering goes crazy it could be some stuff in the parameters. But you have said you have made changes in your transmitter which probably mean nothing in assisted modes.

(Dave) #13

Auto analysis is of little value even if it worked, it needs updating. Post a link to the dataflash log located in a cloud service. They are too large to attach here.

(Rick Bonari) #14

I found that acro and steering modes use Cruise_Throttle and Cruise_Speed parameters. I followed the procedure and used switch 7 on the trnsmitter in manual mode to capture cruise throttle and cruise speed. This part worked fine. I got to thinking the way I did the procedure and it may be why things are not working as expected. I have very limited space inside to do the procedure and had the vehicle up in the air on a box so it wouldn’t crash into anything if there was a problem. Only problem is the accelerometers won’t give a true indication of true speed when vehicle is not on the ground and actually moving. Does this sound correct? I will try setting up shop outside and recalibrate the cruise and throttle speed and then report back what I find. Also don’t like google drive or dropbox but will try uploading the bin file to a google drive and make it accessible to forum. Hopefully all will turn out well. I have the files just need to get them uploaded to the forum. Thanks everyone for the help and I will get back with you all on my progress. This is a great forum and very responsive !!! I forgot to ask if I want to examine the file myself what program would I use to read the .bin file if I can’t do it in mission planner? Thanks much !!! Rick

(David Boulanger) #15

I think the vehicle needs to be moving for that stuff. do it outside so GPS reception is better

(Dave) #16

It doesn’t use the accelerometers for cruise speed it uses GPS. As David says it needs to actually drive with 3D lock to collect the proper data.

Mission Planner or APM Planner 2 for log analysis. Read the Wiki for MP:
http://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html

My 1st Rover was a 4WD basher style truck and it was way too fast even after gearing it down. I sold it and built the next one from a Rock Crawler vehicle and it performs great. You definitely need slow controlled speed for some maneuvers unless you are in a wide open area with no obstacles. Positional accuracy of the standard GPS is not that great when talking about a ground vehicle compared to flying craft plus the reception is worse on the ground.

(Rick Bonari) #17

I have been able to reduce the throttle max speed using transmitter settings. Also in acro or steering mode you drive the vehicle in manual mode to capture cruise throttle and speed. In manual the vehicle drives at the lower throttle limits so it would seem that when I capture the cruise and throttle speed in manual mode actually driving the vehicle it should capture the lower speed that was captured when driving in manual mode at the lower throttle limit. Am I missing something here? If its using the cruise and throttle speed in manual mode it should capture the lower speed that I choose to drive the vehicle at it seems.

(Dave) #18

Sorry, I don’t understand what you are saying. I would set your Transmitter settings back to default. You drive in manual mode at a speed you would normally run at. Hold it at that speed for a bit and hit the switch you configured for learn cruise speed. That’s it. You can set parameters for Min and Max throttle % if you like and for Auto Missions you set Waypoint speed. Set these on the Basic Tuning page or in the Full Parameter list.

1 Like
(David Boulanger) #19

You can also put throttle percentage on the HUD and look at it while moving at your desired speed and then set it in the full parameter list. That’s how I did it but I am using a slow moving boat.

(Rick Bonari) #20

When I set the throttle max to 100% on the transmitter and I drive in manual even at the lower throttle ranges it drives too fast. That is why I set the throttle max speed to a lower setting using the transmitter. It drives much slower in the manual mode as a result. Because I am using manual mode to drive in acro and steering modes when I capture the cruise throttle and speed by activating the transmitter switch to capture these parameters it should capture the lower throttle speed and enter these in cruise throttle and cruise speed in mission planner. Does this make more sense? Also when you switch from manual to acro mode is the vehicle supposed to start moving immediately? I suppose this could be normal but was wondering if this is normal behavior when swithing from manual to acro or steering modes?

(David Boulanger) #21

All setting should pretty much be set in the parameter list , not the transmitter. Make sure you re calibrate your transmitter in Mission Planner