Throttle Min doesn't change with Transmitter off

I’m connected to MP through USB. On the Failsafe page in Initial Setup the Channel 3 throttle value is 982 (stick all the way down). When I turn off the transmitter it doesn’t change. According the Radio Failsafe page ( it should drop to a lower value. It’s not changing.

Scratching my head. Any idea what silly mistake I’m making?

Frsky X8R rcvr connected to Pixhawk through sbus. Frsky Taranis (XD9 Plus) xmitter.



It sounds as though the Frsky X8R receiver is set to hold all channels rather than drop ch3 when it loses signal from the transmitter. Do you know if it can be configured either way?

Perhaps option 2 under Failsafe here is the mode you want? Not sure.

My cheap Radiolink R8EH receiver is NOT configurable but states this in the manual:

Fail safe:
When receiver can’t receive signal from transmitter within 1 second, receiver will output
signal:throttle zero, other channels keep the last signal from transmitter.

Thanks Kenny. I’ve been focused on the xmitter. You raise a good question. I’ll break out the user guide for the X8R.

You are on to something Kenny. I’ve always ignored FS on the RX but the documentation clearly says if it’s not set then the RX will continue to output the last known signals from the TX. Obviously that’s a bad thing. So I went and turned off the TX and pressed the F/S button briefly. Two green flashes indicates it set. Now when the RX loses connection to the TX it’s supposed to set all channels to zero.

But this isn’t happening. No matter what I do MP always shows the last signal received in the Failsafe screen. Something must be over ridding. Thanks for the help though. This gives me a trail to track down.


Hmm. I’m out of tricks! Still pretty new at this, myself. When you fix it, let us know what it was!

I’ve played with a number of Failsafe settings in the TX and none appear to have any influence on what MP shows when the TX is turned off. If I raise the throttle to 1500 and turn off the TX MP shows it still at 1500. TX FS is set to Receiver and the Receiver was set to No Pulses.

I set the receiver by powering off the TX and RX. Turning on the RX and then briefly pressing the F/S button on the RX. This should tell the receiver to send no pulses when it receives comms from the TX.

Maybe MP isn’t working right? I’ll check the logs and make sure that after the TX goes off the RC Out for the throttle isn’t changing.

Log file shows flat Throttle (982) even after I turned off the TX so MP is showing the correct value after turn-off… Can’t for the life of me figure out what’s holding it up when the TX is turned off.

It sounds like you’ve already done it, but perhaps try setting the failsafe on both the rx and tx again. There’s a quick guide here:
Regarding Missionplanner, does a Failsafe message pop up in the HUD?

Thanks James. Yes, I’ve set the TX and RX a number of times. But to answer your other question, Yes, I do get failsafe on the HUD. In order for that to happen I had to reduce FS PWM on the Failsafe page in MP until I heard a beep. This get’s me past the pre-arm fail of Check FS_THR_VALUE. Once I did this I started to get the Failsafe warning on the HUD. The Failsafe page still shows the Throttle Min value of 982 (with TX off) but somehow the Pixhawk is deriving a failsafe condition. Not sure how but guess I’ll just have to live with it.

Thanks to both of you guys for the ideas.


Hi. It is an old title but i wanna ask if you could handle it. i own same issue. could you set failsafe in anyway?

Sorry Ali. I never did figure it out.