Servers by jDrones

The problem of Steering gear and ESC

Hi,guys
When I conected the ESC to pwm2 and let the steering gear to pwm4 it can’t work,but when I connected the steering gear to pwm2 it will work correctly.Why they can’t work at some time.Here is my hardware.Please help me,please.
222222

Can you provide more information? A parameter list would help also.

Which files should I provide?I take some screenshots of parameters.

Hey and welcome,

Normally you have to connect steering servo to pin 1 and esc to pin 3.

Check out this wiki page:

http://ardupilot.org/rover/docs/rover-motor-and-servo-connections.html

I you have further questions do not hesitate to ask.

Best regards

Stefan

Usually people attach a parameter list file. There is some information missing from all the screenshots. What code is this?

1 Like

It looks like PX4 Flight stack to me. The SYS_AUTOSTART paramater defines the vehicle as a custom configuration. For Rover I suppose.

nokasm-You are in the wrong forum. This is Ardupilot.

@DerSchakal1007
I tried to connect steering servo to pin 1 and esc to pin 3,but it did’t work.Thank you for your advices.

@David_Boulanger
I used the official firmware of px4 actually.Because when I flash the rover.apj the GPS will report an error.For details you can view my previous post.

@dkemxr
Yes,I used the official firmware of px4 actually.I flash the offical firmware 3.6.0 of apm,but the MP report BAD AHRs and compass variance.So I tried offical firmware of px4 ,it looks like good.But I can only control one of sero and esc.I connected MP and push the left rocker to bottom right,it reports BAD compass health.When I connected QG and push the left rocker to bottom right,it reports compass sensors inconsistent.I swear,I really like apm.

If you use Ardupilot firmware, you have to calibrate your compass after flashing.

After that normally you won’t get bad compass variance, but you have to take care about the orientation of each compass ( Pixhawk4 and external gps/compass antenna)

Then use Ardurover (APM is hardware) and fix the problems. Many people are using Ardupilot on Pixhawk 4 flight controllers.

There is no point is discussing PX4 here but I’ll make one observation. Did you review the steering and throttle channel requirements for the configuration you have selected? This is what matches the SYS_AUTOSTART parameter you have:

PX4%20rover

Maybe my ways of calibrate compass was wrong.I flashed 3.5.2 but the errors were not changed.The compass1 is green and the compass2 is red.I also find the EKF is red.
%E6%89%B9%E6%B3%A8%20442019-09-28%20103132

33%20%202019-09-28%20102835 %E6%89%B9%E6%B3%A8%20662019-09-28%20103610

I calibrated the compass for times.But the errors also like this:


Post this on the PX4 forum.

I just post it on PX4 forum.Now I’m fixing the error of EKF.I want to change it’s value of examination.

Have you mounted each compass solid to your boat or a plate like that?
After that I didn’t get any error…


Or like that, this is my final installation:

Here is my connection,I used px4,otherwise it can’t disarmed.


When I used 3.5.2,it denied to disarmed.I really don’t know which caused it.I tried to changed the ekf2 some parameters,but it also report ekf error.Even I disabled the internal compass,it also didn’t work.
With yellow light and shine double one time,I think the error was also caused by ekf.

Configure a switch for arm/disarm and don’t change any ekf parameters. These should be set back to default. If PX4 is on there now either work with that in the PX4 forum or flash it to Ardurover and start over. Post a Ardurover parameter file here (not a screen capture, attache the file) after you have made an attempt at configuration and full calibration.

1 Like

I downloaded the firmware from http://firmware.ardupilot.org/Rover/stable/Pixhawk4/ardurover.apj. I want to use ardurover.By the way,my tests were indoor.Which file should I provide?I upload the whole firmware.
ardurover.apj (780.3 KB)

The parameter file. From Mission Planner on the Full Parameter list page use the “Save to File” button on the right side. Before doing this complete the configuration for your vehicle and perform all calibrations. Some details here:
http://ardupilot.org/rover/docs/rover-code-configuration.html

Servers by jDrones