The flight mode (Stabilize/AltHold) is being changed by some reason


Could anybody guys help me to figure it out please? I try to configure the AltHold mode in Arducopter (this is my 2nd day with Ardupilot, was flying with INAV before.

The problem is that by some reason when I take off I need to pull the throttle more and more to climb, but it is not climbing. After moving the stick more the copter does very very sharp move up (about 5-6 meters for 0.1 sec), I have to release the throttle to ‘catch’ the copter in the air, and it seems hovering properly when the throttle is centered. But if I move the throttle up again then the copter hovers again until I move the stick more and more and then the copter flying up sharlply again.

I tried to analyze the logs and as I see the flight modes are being changed in flight between Althold and Stabilize. It seems this is the problem. Please see the logs.

FC: Holybro Kakute F7.

I really do not have an idea what might be the reason. Any thoughts?


change you FLTMODE_CH back to 5. It is 3 which means your throttle also controls your flightmode.

Ahhh. How it might happen? You are right, thank you very much. I definitely not reconfigured this setting so maybe mission planner changed it or it was stock setting after flashing. Now it works great. Thanks again!