The difference between dev and stable

The attached picture is a model to test.

600 hexa. I’m testing obstacle avoidance with rplidar a1, but when I use the developer version, lidar is not recognized.

Power on lidar first, then power on fc and it will be recognized.

Uploading 3.6.10 stable firmware works fine.

In addition, rc7 rc8 cannot be activated in the extended tuning window.

Is there any documentation describing the difference between stable and dev?

thank you~

Either update Mission Planner or configure RCx options in the Full Parameter List.

Thank you for answer.
I know how to set it in RCx Option.
If there is a document describing the difference between a developer version and a stable version.
I’m looking for a way to make the developer version work like a stable version.
Thank you. ^-^

Everything is documented in the ArduPilot GitHub repo. The differences between stable vs. dev will be listed as commits. If you switch to the Copter 3.6 branch, you will see:

You can compare 3.6 to master, but it will be a huge list of 6000+ commits, so that’s probably not the best way to find the differences. You might be better served by searching the recent merged PRs.

thank you.
We are working to resolve the issue.

Can you give me some advice regarding the operation of the obstacle avoidance sensor?

1.first: fc on, second: rplidar on = normal
2. first: rplidar on, second: fc on = normal
3. on = abnormal at the same time (common case when connecting power to the copter)

stable (3.6.10)
1, 2, 3 = all normal


I am trying to us RPLIDAR A1 as a rangefinder for object avoidance for a Hexacopter controlled with a Pixhawk 2.1. I connected the RPlidar to Pixhawk through Telem2 port and set the necessary parameters as described in the Wiki page:

The problem I am having is that I don’t know what to set the parameter RNGFND_TYPE to… I am not getting any reading in the status window for either the sonarrange or sonarvoltage.

It seems that you are working on the same project… could you give some help and insight?

Thank you in advance!

I haven’t used a 360 lidar before, but I don’t think you should expect to see it display readings under sonarrange. That is used for rangefinder altimeters. And I don’t think you should configure RNGFND_TYPE for the RPlidar because those are used for single-point rangefinders.

You might have to use LOG_DISARMED = 1 to record some data to see if the proximity sensor is sending data correctly. I’m not sure if there is a MAVLink message related to proximity sensors that you could watch for.

1 Like

The rplidar configuration for obstacle avoidance is a different parameter from the rangefinder.
Sonarrange doesn’t show anything
If you follow the link attached above, a1 will work fine.
I’m having a problem that doesn’t work according to the power input sequence while using the previous developer version.

1 Like

Thank you for getting back to me, I greatly appreciate it! I have a habit of not being explicit enough when asking questions but I’ll try one more time to state what I need.

I understand now from you and from Anubis’s comment that the RPLIDAR has nothing to do with the RNGFND_TYPE parameter.

Which link are you referring to? Is it the link I mentioned in my comment that shows the wiring and parameter config. like SERIAL1_PROTOCOL… etc?

I followed all the instruction provided in that link and connected the RPLidar to The PH2.1. However, I am at a stage where I want to acquire distance measurements form the RPLIDAR to use in my Dronkit script.

I will use Dronekit to write the necessary Python script that will control the autonomy of the drone. Do you have any idea about the command/function that returns the distance measured by the RPLIDAR so that incorporate that in my object avoidance algorithm?

It looks like ArduPilot sends some information over MAVLink that a GCS can use to display proximity information. I haven’t tried it myself, but according to this, it should report some proximity information within the mavlink DISTANCE_SENSOR message.

That said, if you are developing your own avoidance algorithm, it might be better to connect the lidar directly to your companion computer and controlling the avoidance behavior with navigation messages.

I see you’re using a Cube Black. There were some changes recently in how the FC board boots which affected how some devices were powered.

Interestingly, it looks like a parameter BRD_BOOT_DELAY was recently added to Master that will allow you to add a delay to the boot so the sensor has time to power on. Maybe try using this parameter.

1 Like

Thanks for the advice.
I’ve tested it by changing the BRD_BOOT_DELAY variable to about 4000, but it’s not yet.
I also tried to fix it directly in AP_BoardConfig, but I still didn’t find a cause that didn’t work.
Let’s continue testing. Thank you. ^-^

The lidar powered by a separate BEC, right? (I looks like it is in your picture, just making sure)

If it is, then I’m not sure what might be causing this. If this problem happens every time, you might want to create an issue in the ArduPilot repo.

1 Like