Testing motors with no props on a table, is FC reacting weird? [solved: no it is not]


I’ve tried testing my X8 configuration drone motor reaction on a flat leveled table.

I’ve removed my props and activated only my throttle, and tested the reaction of the motors in response to lifting one of the sides of the drone.

I would expect either the motors that are raised to slow down and/or the motors that are not raised to speed up in an attempt to get the drone “level” again.

But to my surprise some of the motors reacted as expected and others completely opposite.

Is this a normal outcome for a test like this? If so, can you please explain the logic behind it? And if not, could you tell me either how to fix it or what’s wrong with it?

Here is a link to the Mission Planner log bin file of the test:



Follow How to methodically tune (almost) any multicopter using ArduCopter 4.4.x and read the section about motor testing.

1 Like

Can you take a look at the table test log file and see if there seems to be any obvious problems?

Here is the link:

My time (and yours) is precious.

We spent a lot of it compiling the document I posted (and many developers and users reviewed it), so that users can configure their systems faster using less iterations. A single document will teach you UAV configuration and flight dynamic engineering. Use it.

There is little to see in a .bin log file of a propellerless UAV.

1 Like

Thanks, I’m in the process or reading your document.

I’ve looked into the section you recommended about motor testing (2.14) and figured out that in my X8 drone, the order of letters seems to be different from what ArduPilot describes as the correct order.

Here is the order described in ArduPilot:

X8 Motors

But the order that i get when executing a motor test in Mission Planner is:

I assume this is a problem, but i’m unsure how to fix it.

So you got the motor order wrong. Re-order them until they are right.
Also, looking at your .bin file fmuv2 is almost certainly the wrong firmware for the Flight Controller. Which Flight Controller is it? This has nothing to do with your motor order problem.

1 Like

It’s a PixHawk 2.4.8

I think that I’ve re-flashed the PixHawk via QGC, but then was unable to flash it again via Mission Planner, could that be the reason? How do i fix it? I want to work with Mission Planner, not with QGC.

Depending on which 2.4.8 (those are generic FC’s) Pixhawk1 is usually the correct version. Go here and download the .apj file and then use Mission Planners “load custom firmware” option on the Install Firmware screen to flash it.
If you get error messages, barometer perhaps, then try this version:

1 Like

I have received the same error for both PixHawk1 and Fmuv3 ,which is:

“ERROR: Firmware image is too large for this board.”

You said that PixHawk 2.4.8 is a generic version, could you tell me please, how do i check the specific version e.g. Pixhawk1, so that i can figure out the correct firmware to use.

Does it say 2.4.8 on it? Every one one of those I have seen is a 2mb board. If it’s a 1mb board then you need this firmware:
Pixhawk 1-1M

But, I would suggest a new Flight Controller.

Is it a Radiolink FC by chance? If so, throw it in the trash.

1 Like

i’ve just now tried flashing FMUv2 and it was able to flash, should i try PixHawk 1-1M anyway? Are there substantial differences between them?

1 Like

Yes. That’s the proper firmware for 1mb boards.

Does it say 2.4.8 on it or are you guessing that’s what it is? Is it old? Because it would be an anomaly.
After flashing Pixhawk1-1M post a screen capture of the HWID screen in Mission planner. Let’s see what’s on that board.

1 Like

It says 2.4.8, i bought it about 7 years ago.

I’ve successfully flashed PixHawk 1-1M and here is the screen capture of the HWID:

OK, fix the motor order and you can advance.

1 Like

Please refer to the following link :–


1 Like