Pixhawk 1 or Pixhawk 1-1M, how to know

Hi all,

I want to update my Plane firmware. I have a Pixhawk 1 (not cube) from 2015-2016.

How do I know if it is Pixhawk 1 or Pixhawk 1-1M?

I read another post but it isn’t clear for me.


1 Like

Use QGroundControl. Navigate to the Firmware button and reconnect the board. What does it say for flash size? If it’s ~1mb then use Pixhawk1-1M, if it’s ~2mb use Pixhawk1. While you are there use QGC to flash the firmware.

also this link might help

Thanks for your answers,

Mine is FMU V2 and flash size is 2080768 (2mb):

Searching about FMU versions I found this on the PX4 User Guide webpage:

So I understand that if you have FMUv2 you have to install:
-“Pixhawk 1-1M” or
-“fmuv2” firmware

And that although FMUv2 has 2mb of flash it is limited to being able to use only 1mb.

Do you agree?

Old pixhawks are 1m
If QGC show 2m install Pixhawk 1 not Pixhawk 1-1m

In your case you need to install Pixhawk 1

I folowed this video, maybe it can help others:

And discovered that my Pixhawk 1 has the 1mb flash limit, so I have to use the “Pixhawk 1-1M” version of the firmware.

All I have to know know is what parameters are missed in the “Pixhawk 1-1M” version.

I don’t think so. The flash size shown in QGC should be right. That process using terminal I think would only work if you were running an old version with Nuttx OS. That Video is ancient.

This is what a 1mb version looks like in QGC:
1mb flash Pixhawk

But run Pixhawk1-1M if you like. Of course it will work you will just lack some features.

Did you got “warning warning warning warning” message?

Yes @hosein_gh,

This is the message:

@dkemxr Yes it had an older Nuttx version, that’s why I wanted to update Firmware. I can deduce that it has 2mb flash memory (as QGC says) but as I had the “warning warning warning” message, the flash is limited to 1mb.

interesting it seems that QGC was wrong
using “ver all” command with Nuttx is more trusted

That is interesting and you are probably right. If you do manage to flash a 2mb version on a 1mb Pixhawk, which I have done many times on the bench, the 1st thing that will happen is USB will disconnect randomly. “Internal Error xxxxx” will also show up on the Messages screen in Mission Planner.

@dkemxr I had red about those USB connection problems. As for now, with Pixhawk 1-1M I have no problems.

Thank you both for your answers.

1 Like

Any idea why QGroundControl displays a flash size of 2MB, and I can flash arduplane for Pixhawk fine, but then later QGroundControl starts complaining I need to use the Pixahawk1-1M?
Firmare I tried: ArduPilot firmware : /Plane/stable-4.3.3/Pixhawk1

Found device: PX4 FMU V2
Connected to bootloader:
Version: 4
Board ID: 9
Flash size: 2080768

Which flight controller is it actually?

It is the 3DR pixhawk 1 with 2MB flash.

It’s because you have fmuv2 on there. Update to Pixhawk1. I would suggest downloading the .apj from here Pixhawk1
And use Mission Planners “Load Custom Firmware” to flash it.

Flash results:

Found device: PX4 FMU V2
Connected to bootloader:
Version: 4
Board ID: 9
Flash size: 2080768
Downloading firmware...
From: /home/ryan/Downloads/arducopter.apj
Download complete
Firmware file missing parameter_xml_size key
Firmware file missing airframe_xml_size key
Successfully decompressed image
Erasing previous program...
Erase complete
Programming new version...
Program complete
Verifying program...
Verify complete
Rebooting board
Upgrade complete

Rebooted, then, same thing displayed, same error in UI.

Found device: PX4 FMU V2
Connected to bootloader:
Version: 4
Board ID: 9
Flash size: 2080768

I am failing to understand what is wrong with the FW I just flashed that I linked above. It’s for Pixhawk1, no, but for plane.

Would my board be subject to the following bootloader issue posted on PX4? Bootloader Update (FMUv2) · PX4 v1.8.2 User Guide

When you connect with Mission Planner, from the messages screen what version does it say? Forget about QGC for now. These messages:

I see you double posted this. Good luck in the other thread.

1 Like