Terrain following with spline WP on OmnibusNanoV6 not supported?

I have an OmnibusNanoV6 with rangefinder TFMini running Copter 3.6 with Chibios.
To use rangefider im Mission Planner I change “Relative” to “Terrain”, see screenshot below.
When Uploading the WPs I get error Message “MAV_MISSION_UNSUPPORTED_FRAME”.

Is there a reason why terrain following with spline WPs is not supported in this configuration?
How can I make it work?

It is working fine on another copter with mRo X2.1/Chibios.

20181101-OmnibusNanoV6.param (14.0 KB)

Can it be, that parameter " TERRAIN_ENABLE" needs to be enabled?
But on OmnibusNanoV6 this parameter is not there.
Probably because Terrain needs dataflash memory to store the terrain data.
But the onboard dataflash is not supported.

This would really be a pity, because for rangefinder attitude control the terrain data would not be needed.

That’s almost certainly the reason. I tried loading a Mission like yours on to one of my F4 Nano V6’s and got the same result. On a Pixracer it’s good to go. I’m finding not having dataflash is a significant handicap. More for tuning purposes for me.

OK, this seems like a bug. I don’t think we should be rejecting the terrain mission commands because there’s a lidar attached. I’ll add this to our list of things to fix in 3.6.0.

EDIT: issue created here.

1 Like