TELM port 2 setup with rfd

I’m not able to connect my Rfd with the Telm 2 port. I have Configured all the parameters according to this .Please help me.
Thank You.

What hardware and which firmware version are you using?
And which FW on the RFD900 device as well?

Do the radios get a solid green LED or flashing?
If you do the wiring correctly these settings should work “out of the box”


or try
to disable Clear To Send/Ready To Send

Can you use RFDTools or MissionPlanner to provide a screenshot of your radio settings?
Something like this, but probably with different values


i am able to connect with the telm 1 but not telm 2

Update to ArduCopter 4.1.0-beta8. Your 4.0.4 is ancient.

but i think it is not that much old that I can’t even configure the serial ports

There have been fixes, especially if you are using CubleBlack.
But it is your decision.

Im facing the same thing in firmware Arducopter 4.0.7. please help me

What HW are you using. You still have not answered my questions above.

im using Cube Black arducopter version 4.0.7.

In that case I advise you to update to 4.2.0-dev from: it fixes some issues with Telem2.

if it still does not work and you tried the parameter changes described above (after rebooting) you have an hardware issue.

but it is still under development
it is safe to use

  • You are having an issue. You tested changing the parameters like described above, it did not work.
  • It works fine for you on Telem1

It might be time to test something new.
Like Einstein said: “The definition of insanity is doing the same thing over and over again and expecting a different result”

It is still under development. It is mostly safe. We have a ton of CI tests on it.

Are you saying the radios work OK using Telem1 but not Telem2 ?
And your screenshot is the settings in use, and the radios of a solid green link LED ?

If so the only option may be to use the 4.2 Dev firmware, as amilcarlucas says.

Also I thought with default baud rate settings, the Max Window would be about 33, not 20. That may not be a big problem though.

Yes I can connect with the telm 1 port and these settings are from that port.
And when I connect with the telm 2 port I’m not receiving any blinking of green light in air unit of Rfd.
I’m receiving the same problem with the another brand new cube Carrier board with the 4.2dev firmware

Are you powering the RFD900 from an external 5vdc BEC?
The Cube Telem1 port may power it since it allows 1amp (I think) but the Telem2 port will not power high current devices like a telemetry radio.
If you are going to use the Telem1 port and power the radio from that port, maybe turn down the TX power a bit, like 27dbm is about 0.5watts.

That i know but i am using pixhawk kore board

When using Telem2 port, do you get the green LED on the modem at all? Binking or solid?

No, sometimes I get the blinking for few seconds