Telemetry via wifi from H743

Hello, I have my traditional Heli system fully working with the exception of getting the telemetry to work. For the last week I have been researching with no luck. The setup was followed as per the

Config: Matek H743-Mini + M10Q-5883 + SVPDB-8S + Adafruit HUZZAH ESP8266

I have RX6 used for SBUS. I have tried RX7/TX7 Mavlink set to 1 and 2 with no luck. During messing around stripping everything off and reconnecting I had ardupilot communicating via UDP with my phone and able to see everything correctly. But, had lost RC. I think I must have connected it to the SBUS in my trials.

I have not been able to duplicate the limited success on a different channel .

I can connect to the ESP8266 access point and see data with the USB disconnected.

Connecting to TX7/RX7 UART7 telem1 SERIAL1
BRD_SER1_RTSCTS=0 (tried 1 also)

Any assistance with this would be much appreciated.

Error Fixed.

Through all my reading I assumed that mavlink1 and mavlink2 were two different formats, this since mavlink2 has additional capabilities as per the wiki.

On Ray’s blog there was one reference that SERIAL1_PROTOCOL is mavlink1 and SERIAL2_PROTOCOL is mavlink2.

Changed SERIAL1_PROTOCOL from 2 to 1 and all now working.

To sum up:

Arducopter V4.4.4 - Matek H743-MINI - ESP8266 Wifi
Connecting TX7/RX7 on H743-MINI