Servers by jDrones

Telemetry - Air and Ground not pairing

Hi everyone,

I am almost done on my first quad copter build but I have trouble with the telemetry module has it has never wanted to communicate between air and ground…

This is a 433Mhz 500mW

I managed to get drivers for windows, but no change.
I also tried to modify the arducopter file, nothing changes either.
I also tried to change the baud rate to 57 and no changes…

Below are details of my steup:

Have a look at this thread: Telemetry system not connecting

Also, make sure your Net ID is the same on both radios.

Thanks Allister. How do you make sure Net ID are the same on both side ?
I do not know any way to tweak these details…

I think with your radios you should be able to connect each one to your computer and set them up through mission planner. Plug them in to the computer, but don’t press the “connect” button. Once it’s plugged in you should be able to go to the initial setup tab and find mavlink radios there.

Thanks Allister.
As the model showed in the link you shared, I only have a USB port on the ground stick. Is there any way to connect the air stick to my computer ?

Sorry, I don’t know that one. All the radios I’ve used I’ve been able to connect both sides to the computer for setup. Maybe there is some way to go through the flight controller and use it as the USB conduit.

You use an FTDI adapter to do that.

Servers by jDrones