Telemetry system not connecting

Hello,

I am using the following 433 MHz antenna set (check image) for my quadcopter, for the last 6 months now.

However, it has now stopped working. The green light keeps on blinking

Maybe I have upgraded the ground module from Sik radio by mistake. But I am not able to upgrade the air module as it does not support a micro usb connection like a Sik Telemetry radios.

Can anyone please help me out?

Thanks

Hello,

You can use a standard FTDI module to flash the unit.
Or any other device that can read from USB to serial ,like an Arduino.

1 Like

That was much helpful @ppoirier.
Thanks a lot.

I am still facing some issues with it.
In the Ground module - it is rfd Sik 2.0 on hm_trp whereas it is rfd sik 1.9 hm_trp in the air module. After correcting other parameter settings, I tried to connect both the modules. Both are now showing solid green led. However, they are not connecting through mission planner.

If it is necessary to have the same firmware on both the modules, please share the link for downloading the firmware.
(I have tried multiple baud rates too.) Check image for Ground and air module.

Thank you

Make sure you have same parameters on both unit as I see on radio set to MavLink transport and the other is raw data

Check your FC serial speed must be set to 57600 as well

1 Like

Ok, Thanks. I will check and update.

You should have the same version of firmware on both radio’s.

I have checked and done the settings. It is working fine now.

Thanks for that FTDI module information.

Thanks a lot.

Hi I am having the same issue that you were. I ordered the FTDI module and it should arrive tomorrow. Were there any particular steps that you took to make sure it was updated or on the same firmware?

Hi I am having the same issue too.I have the same settings and firmware on both module.But they are not linking to each other.I am using sik radio telemetry v2.can someone please help?module 1
module 2

Click below: