Tarot 650 uncontrolled descent

I was in stabilise mode flying my 650 quadcopter at height and reduced the throttle to zero (or very low) so that the drone would drop rapidly.

Unfortunately, upon applying positive thrust to the motors, the drone did not start going upwards but continued downwards until it crashed into the ground.

Is this an Ardupilot issue do you think or was it caused by the 15 inch props windmilling in the wrong direction and the ESCs being unable to fight the reverse direction?

If so, is there a way to force the ESCs never to allow reverse direction? I think I have Dshot ESCs but am not sure as I inherited the drone from someone else.

I am able to provide logs but would prefer to anonymise the location so please could someone tell me what I need to provide and I’ll erase that info.

I’d be very grateful to hear opinions. Thanks.

What do you have MOT_THST_MIN set to? To quote Mr. Hall a Developer:
MOT_SPIN_MIN should be set high enough to get strong rotation but only a small amount of lift.

1 Like

To add to @dkemxr comment, you were also dropping through your own ring vortex which would have decreased the lift response by quite a bit.

Inertia kills.

Basically what happened is YOU put the aircraft into an uncontrolled descent. As the aircraft accelerated at 32ft/sec/sec, its inertia increased to the point where the crash was inevitable.

The bottom line is this crash was caused by pilot error.


I have MOT_SPIN_ARM appears to be unset completely in Advanced Params. I know that once the drone is armed, the motors do NOT spin.

MOT_SPIN_MIN is set to “Default”.

Is this info of help?


I’m not sure there was that much VRS as I was in a sort of free fall and any initial thrust would be in the opposite direction to that which creates VRS, but I think it’s something people should always be aware of when flying.


This thread is about the drone not responding noticeably to a strong (100%) positive thrust in a drone that is normally extremely responsive and has a thrust:weight ratio of 4. As the drone descended it had at least 2 seconds to recover but did not. Normal response time with my setup is I would say no more than 0.5 seconds.

I know what this thread is about. You said yourself that you went to low throttle so the aircraft would descend rapidly. After that the laws of physics took over and you lost.

In the first second the aircraft fell ~ 5 meters. After 2 seconds the aircraft would have fallen ~20 meters. If the aircraft was at an altitude of less than 20 meters AGL, 2 seconds was not enough time to recover anyway.

So the question is, how high was the aircraft when it went into free fall and how long was the aircraft in free fall before you applied any throttle?

Without the flight log it is all conjecture and you have already had some very knowledgable people give you they views on possibilities.

For anything more you would need to provide a .bin file from the FC for that flight.

Is .log okay or must I provide .bin?

Post the .bin its smaller…

Ah, I just uploaded the .log here:

It is only 4.5MB. Now you know where I live. :smiley:

There is no real surprise here. You dropped the throttle in Stabilize, the craft starts the Return To Earth mode (bad joke). After it plummets ~10m you max the throttle and the motors (only one shown for clarity) are commanded to max. If we had ESC telemetry we would see the motors not turning but what we do have is current and it’s low. 2s after you raise the throttle it hits the ground. All pretty well predictable.

If you want to race to the ground by dropping the throttle you will need a MOT_THST_MIN high enough to keep the props spinning and providing some stabilization.

Also see Air “not really a” Mode:

And before flying again I would suggest setting the Basic Tuning parameters. In Mission Planner connect to the craft and hit Alt>A, enter the values as prompted and set what’s suggested except for the Gyro rate. Leave that at 20Hz for that size craft.

1 Like

Thanks for checking out the log.

The surprise to me (and anyone who is new to Ardupilot) is that I command high thrust but for the next 2 seconds the motors do not consume the current you would expect when the user applies high throttle.

In the graph, is RCOUT the actual PPM signal sent to the servo? If so, that is reassuring that Ardupilot is doing its job.

This is the thing I’m worried about; in your opinion do you think my ESCs are the root of this problem of the motors not spinning (in the right direction!) in response to a throttle input?

MOT_THST_MIN does not appear as a parameter in my Ardupilot. Do you mean MOT_SPIN_MIN? Mine is set to the default value of 0.3 but I guess if I test that now, I will see it is not sufficient to spin the props.

I’ll look into the tuning for future stabilise mode flying. Also air mode looks useful.

Sorry right MOT_SPIN_MIN. Use Mission Planners Motor Test function to determine when the motors spin. Props off.

1 Like

I think in summary my problems were twofold:

  1. I should have set MOT_SPIN_MIN. I had no idea how vital this is. It’s not even listed as a mandatory part of the setup wizard in Mission Planner.
  2. My ESCs are crap and were unable to respond to positive thrust once they were windmilling backwards.

Probably a good assessment. Which ESC’s are they? Hopefully they don’t look like these. Or the premium ones with Yellow Shrink Tube :smirk:


I have the yellow shrink ones on a different drone. As I bought them in two batches a few months apart, the minimum PPM to spin the motors is very different - my drone jerks one way then the other as it takes off. :sweat_smile: I think if I set MOT_SPIN_MIN it will fix the jerking take off. I have had two of the yellow ESCs blow up. One from a crash and one when I used it the first time.

As for the drone that crashed (now mended), I have the following ESC:

I inherited it, so I’m not sure if it’s any good. All I know is it is efficient but needs a lot of throttle to move the props. The motors also make weird noises at low throttle. :-/

It’s probably no good then, throw it away if you have any doubts about an ESC.
If you want to stick with 4in1, get a Holybro tekko32 45A 4in1 and disable Low RPM Power Protect then you are good to go.

1 Like

Agree with Shawn, in the bin. I don’t think a 4-in-1 makes a lot of sense for a big craft as cooling can be a problem. Not so on mini quads. I don’t know where you are but the house branded RaceDayQuads single ESC’s are a great value and so far good performers for me.

1 Like