Tarot 650 uncontrolled descent

Cool. I appreciate the suggestions.

I’ve just checked the ESCs for MOT_SPIN_MIN and it works out to 8%. As the default setting is 15%, I only assume that when there is a reverse wind blowing (i.e. in freefall) you need much higher than 15% to counter the wind acting against the props.

As I cannot check what this value should be unless I have a wind tunnel or drive with my drone held out the window, I will use Air Mode in future to guarantee stabilistion. If I understand it, I just need to map a switch on the Tx to ARM instead of using the traditional low-throttle-right-rudder method.

You could do that. I think I would carefully play around with Motor Test with the craft held down and see what % produces some lift but not enough to get off the ground. I suppose you could determine this with increasing MOT_SPIN_ARM values. Set a Motor Emergency Stop switch so it doesn’t fly away :grinning:

It’s a good idea but then I run the risk of it taking too long to come down from high up because of the minimum thrust.

I think I’ll just have to be super careful when descending in stabilise mode. I will do a high up test and kill the throttle at 120m and hopefully I’ll manage to recover before ramming into the nice ploughed field that I went into the other day. :grin:

The copter will most probably not take off with 15% thrust. Just put the copter on a scale and see how much the weight reduces when you do 15% throttle. My gess is that it will give you 50g lift :slight_smile:

1 Like

Remind me not to fly with you.

1 Like

Also it sounds like the ESCs were never calibrated . If it takes the throttle stick halfway to half throttle before the motors start to spin, that’s not good especially if you are heavy. And chances are you are not getting full throttle at full stick travel. That can also be the reason you got no response, especially if your battery was low.

1 Like

Thanks, I’ll try a recalibration although I could have sworn I did that already.

Yes, try to do it with the radio and not through MP. Throttle stick full up before plugging in battery.

Are you sure that will make a difference? I ask because ultimately, the ESCs will be connected via the Pixhawk, not the receiver, so it is surely better for the Pixhawk to set the range during calibration that it will use?

Some people just refuse to do things the right way.

The reason I suggest through the radio is because that way works very well for me. I,m no expert on this stuff, so as a result I binge watch videos from people who has been doing ardupilot and opentx for years. Several said that’s the way they do it and I copy. I have a Tarot 700 quad with gimbal, camera and a 5000 5s pack. I’m off the ground mid way to half throttle. My planes are the same. You just have to make sure your values at low , mid and high throttle are what they suppose to be. 900, 1500, 2000. As a matter of fact on the arducopter page they say that is one way to do it.

The all-at-once method in the arducopter docs is the way to do ESC calibration.

I’ve been doing this a long time and I have never seen this. Show me…

Thinking about it, the take off problems are actually because I have been using loiter mode to take off. Apologies for the misunderstanding. I still need to recalibrate though as the previous owner had god-knows what settings.


First paragraph in " About ESC calibration".

That paragraph says nothing abut using 900, 1500 and 2000. It does say, " Alternatively with Copter-3.4 (and higher) you may manually set the MOT_PWM_MIN to 1000 and MOT_PWM_MAX to 2000."

Correct, actually the 900 is my settings for RTL. Also I was referring to the radio settings not MP and if you have emergency rtl it’s lower than 1000. At least for me it is. Throttle safe or cut is below 1000.

Please be cautions with “kill the throttle at 120m…”. If you haven’t got everything set just right you are certainly going to enter vortex ring state. It’s common for many multirotors to actually have lower descent speeds than climb speeds. Look up the specs for many of the DJI units for example. Increasing the throttle will not correct for VRS, in fact it will worsen the condition and just bring the planet closer to your drone. You need to move horizontally into “clean” air.

1 Like

Thanks, I fly helicopters in flight sims so am all too familiar with VRS.

I think my biggest issue is the ESCs not starting the motors properly but once started I will look out for VRS.