Taranis X9D+ doesn't allow flashing of R-XSR

Dear Ardupilot community,
I am trying to flash my R-XSR.
I am following these instructions.
However when the person is going to the SD-Card on his Taranis, chooses the .frk file he can chooses "Flash external device, Flash internal device, …
However, for me only “Delete” appears, nothing else.
I switched the two cables as he showed earlier.
My OpenTX Version is 2.0.17.
Might it be the slightly old version that causes this problem?

Yes, update OpenTx to latest stable. Or use the Frsky STK tool if you don’t want to update OpenTx

Now it works. Thank you!
I got a tiny problem though.
According to Companion the latest version is 2.2.1(cca71808), but each time I turn on the Taranis I get the error, “Expected verson: 2.2V0013” after which I can get to the main menu by pressing any key.
Can I ignore that or is it important?

What version does the radio say is installed and what version is shown in the “opentx.sdcard.version” file in the root directory of the SD card? I have seen some posts about a mismatch here but not sure how it happens.

The radio says the version is “2.2.1(cca71808)”.
Where do I find the file “opentx.sdcard.version”?
I did a search while being in the main SD-Card folder, this file doesn’t seem to exist.

You can download the 2.2.1 SD card contents for your version here, then copy it to your SD card in the Taranis.

I find it’s very slow to copy over a USB cable to the Taranis - much quicker to just take the SD card out of the Taranis and mount it directly on the computer.

It should be right in the root directory.


Dave, the root directory of my CD Card looks like this:

Anthony, I downloaded the files for the X9D+ from the link you provided, cleared the CD-Card out and put the files onto it.
I do not get the error anymore, thank you!

Immediately the next problem occured.

I am trying to bind an R-XSR receiver to the Taranis X9D+.
I am following this video through.
The R-XSR is in SBUS mode; I created a new model on the Taranis with Mode: D16 and Channel Range: CH1-16.
When I turn the receiver off and start the binding on the Taranis I hear the beeping sound.
However, instead of it starting to beep and blinking “BIND” on the screen right away I have to chooses one of “Ch1-8 Telem ON”, “Ch1-8 Telem OFF”, “Ch9-16 Telem ON” and “Ch9-16 Telem OFF”. I chose the first.
When I keep pressing the bind button on the R-XSR and give it power again
the green, blue and red LEDs are on. It’s not that the red one is flashing like in the video.
Also when I want to check if it has been bound, I just get stable blue and flashing red (so showing that it’s in SBUS mode again), and not the green and blue LED.

Did a firmware update/ flash on the receiver, didn’t help.
Might it be a problem, that it is connected to a PixHawk1 to Telem2 and RCIN (as shown here with the telemetry cable and adapter bought here)
I had the non EU version firmware on the Taranis. Now that I do it still doesn’t work.

EDIT: I opened another thread for this since it is a completely different topic.