Taranis X9D+ and R-XSR don't bind although newest firmwares are installed

I am trying to bind an R-XSR receiver to the Taranis X9D+.
I am following this video through.
The R-XSR is in SBUS mode; I created a new model on the Taranis with Mode: D16 and Channel Range: CH1-16.
When I turn the receiver off and start the binding on the Taranis I hear the beeping sound.
However, instead of it starting to beep and blinking “BIND” on the screen right away I have to chooses one of “Ch1-8 Telem ON”, “Ch1-8 Telem OFF”, “Ch9-16 Telem ON” and “Ch9-16 Telem OFF”. I chose the first.
When I keep pressing the bind button on the R-XSR and give it power again
the green, blue and red LEDs are on. It’s not that the red one is flashing like in the video.
Also when I want to check if it has been bound, I just get stable blue and flashing red (so showing that it’s in SBUS mode again), and not the green and blue LED.

Did a firmware update/ flash on the receiver, didn’t help.
Might it be a problem, that it is connected to a PixHawk1 to Telem2 and RCIN (as shown here with the telemetry cable and adapter bought here)
I had the non EU version firmware on the Taranis. Now that I do it still doesn’t work.

First, I don’t have a R-XSR receiver, but I have a number of X and D receivers, and the only time I had problems with binding was when I had mixing EU and non-EU firmwares. Once, I was even trying to bind for a few hours cause I was sure they had matching FW’s, and they didn’t, so please flash both with EU (or nonEU FW) and try again.
It shouldn’t matter if they are in S-BUS or PPM output, but make sure that on both the D16 mode is selected.

I have now flashed the Taranis with OpenTX Companion.
The downloaded file is called "opentx-x9d±eu-lua-en-2.2.1.bin.
So as far as I see it, it should be the EU firmware.
Then I flashed the R-XSR with the file “R-XSRLBT171103.frk”,
which is, as far as I know, the EU conform version, or is it?
I got the same problem as before when trying to bind.

Not sure about the R-XSR firmware as there is only one version of the FW, but, as there is an EU certificate accompanying it I would assume it is the EU FW.
There is a new FW version (2.2.2) for the x9d+, you could try with it.
Wait, are you sure that your internal XJT is the EU version?
I would flash it with the EU firmware also.

No, I did not flash the XJT module.
I read something like “Graupner” and thought just people using their stuff need to do that.
I flashed the XJT module following this description.
Now the binding worked, green and blue LEDs are on now.
Thank you, Igor!

You need to flash you internal XJT module, it works after update.