Takeoff without GPS


To takeoff an arducopter using any MAVLink ground station, I noticed that it was necessary to have a 3D fix for the GPS and the copter must be in GUIDED mode.
However, this is only possible in an outdoor environment to be able to get the 3D fix of the GPS.

I wonder if it is possible to takeoff the copter in an indoor environment WITHOUT need to have a GPS fix. Some quadcopters like AR.Parrot drone allow this and estimate the altitude using its ultrasonic sensor pointing to the ground. But, with Arducopter, I could not find this possible.

Do you have any hint to make a copter fly without GPS fix in any mode different from GUIDED? If so, how and what kind of sensor will estimate the altitude?


Guided mode uses GPS lat/lon for the position it is sent to.

For indoor/ no GPS you would want to use a flow sensor.

I’m also trying to take off the copter indoor by sending the MAVLink commands from ODroid companion computer.

APM Planner shows that GPS Fix = 1 and GPS HDOP = 99.99. I’ve disabled the GPS pre-arm check and removed the propellers to make it more safe indoor as I don’t have much space.

ODroid can arm the copter but when the copter is in GUIDED mode and the take off command is sent, the copter doesn’t take off and the speed of the rotors don’t increase.

I’m not sure if Guided_NoGPS can help? It’s mentioned here that it should do the job but I couldn’t find any more details.

Any hints to enable the copter to take off?
Thank you

I tried flying outdoor. The GPS Fix became 3 and the GPS HDOP became 1.2 and the UAV took off successfully.

1 Like

Hi All,
If you are able to get your quad flying indoors/without-GPS, can you point me to how you got that running?
I posted my question on the “Is ArduCopter functional without GPS?”. Possibly an incorrect thread. As we know it is functional without GPS.

I followed instructions listed at “http://ardupilot.org/copter/docs/indoor-flying.html” but no luck.

Frame: QUAD
Pixhawk1 002C001A 3337510D 31313639
ChibiOS: 57801550
ArduCopter V3.7-dev (1c3d90d8)

I am using a Pixhawk 2.4.8 with a RPi3b as a companion computer.

I removed the external GPS. I think it just broke when the quad crashed during some bring up session. So, want to try without GPS. I just want it to go up ~9 feet and stay there. Until I give it a command to land. Just hover at the height in one location.

I tried the following, but no luck.

ALT_HOLD> arm throttle
ALT_HOLD> Got MAVLink msg: COMMAND_ACK {command : 400, result : 0}
Arming checks disabled
arm throtttakeoff 25
ALT_HOLD> Take Off started
Got MAVLink msg: COMMAND_ACK {command : 22, result : 4}

Did you get the solution if yes…Kindly help how did you do that please