Takeoff blocked: Waiting for ESC RPM error

Hi all,

I tried a motor test by connecting my laptop to the flight controller and the motor test does not work and says takeoff blocked: waiting for esc rpm. However, when i power the flight controller and drone with the battery and connect a telemetry radio to my laptop, the motors do work but the same error shows up. I will list my parameter file.

LatestParametersfor4.5.2.param (18.3 KB)

A log with LOG_DISARMED would be more useful.


Am I mean to keep that parameter as 1 then do both motor tests so it logs them both even when disarmed?


I have attached the logs where i attempted the motor test via usb and when i connected with battery instead. I am not sure which log file it will be, either one or could be both but it is out of these.


Set these:


Hi Dave,

Thank you, I will set these tomorrow, I also updated the firmware to 4.5.2

What did you set this?

Because you haven’t configured for Bdshot correctly you don’t have ESC RPM.

Hi Dave,

Are you asking what I set TKOFF_RPM_MIN as what value? Yes I did realise today I haven’t set it properly. Is there a guide for this as I didn’t really find anything. I think before as well the esc rpm error was there as well but I didn’t check messages because I was assuming it was previously the errors only that showed up in red.

I’m asking why you set it at all. Default is 0

Hi Dave,

I’ve actually never touched that parameter. This is the first I’m seeing of it. I will change it to 0 though.

Set LOG_DISARMED back to 0 also or you will fill your Sdcard with files. This is not needed now.

Hi Dave,

I believe I did that today before I left. Should I also change the parameter back to 0 as well? Not sure if it makes a difference.

Hi Dave,

That’s fine then I’m sure I did that already, I’ll double check when I’m in again.

Hi Dave,

I changed these parameters to what you mentioned and i connected the battery and one of the motors started bugging and randomly moves and stops a little, so I had to change BDMASK to 0 and MASK to 3840 again.

Set them back and then set:
MOT_PWM_TYPE,5 (dshot 300)
And confirm what actual ESC’s you have.

@dkemxr, @Sold The component Editor window of the ArduPilot Methodic Configurator software provides a way for the users to document their components, and a way for us (in support) to get that information without having to ask the users.

It would be good for the entire community if we all started to use the software more often.

Hi Dave,

I’ll change the MOT_PWM_TYPE to 5, as for the ESC, it should be the BLHeli S ESC 20A (4 pcs) with XT30 Plugs.

Hi amilcarlucas,

I will look into using this software since it makes it easier for everyone.

Confirm that’s what they actually are. Is there a label on them that says that?