Takeoff blocked: Waiting for ESC RPM error

Hi Dave,

Yes it is these ESC’s.

OK, then try Dshot300 and set the Servo parameters back to what I posted.

Hi Dave,

bdshot300 is set and SERVO_BLH_BDMASK is 15 and SERVO_BLH_MASK is 0. I tried a motor test with my fc connected to my laptop and the same error comes up in messages and motors don’t spin. Do you think it could be related to the TKOFF_RPM_MIN and MOT_SPIN_MIN and MOT_SPIN_ARM values?

Post the parameters file again. TKOFF_RPM_MIN is set to 0 now right? You are using Motor Test?

Hi Dave,

Yes TKOFF is 0 and I tried motor test, which worked with no take off blocked message coming anymore but now I tried to create a flight plan, arm it but the error comes up now as PreArm: Need Position Estimate shown in the picture below. SmartRTL deactivated: bad position.

Screenshot 2024-05-15 150327
dshot300takeoff0bdmask15mask0.param (18.3 KB)

I changed RNGFIND1_GND from 10 to 18 as I put the drone on the floor and it was fluctuating between 18/19. I tried to fly it again, same SmartRTL deactivated: bad position and Mode change to AUTO failed: requires position comes up on messages.

Look at the 1st Note on this Wiki Page linked to several times now:
Non-GPS navigation. Try it.

And (or ignore this if you don’t care about getting it right):

Hi Dave,

Thank you. I believe I’ve set up the Mateksys 3901-L0X but I will re check the parameters for that. Do I look at GPS/Non-GPS transitions in the link you’ve posted? Or should I just recheck the optical flow?

I’ve already changed MOT_PWM_TYPE to 5 I believe and I will change the OTYPE tomorrow.

Can you just follow the instructions? I’ll write it again:

Not in the last log file you posted.

Hi Dave,

Sorry for annoying you. I was just a bit confused since I did the optical flow. That’s fine, I’m not sure why it wasn’t set to 5 but I will definitely set that and OTYPE.

That link doesn’t directly link to Optical Flow. Did you see THE FIRST NOTE in the link? Did you try it?

There is a huge graphic below the note.

Or use the Lua example and put your GPS coordinates in it. If you are going to take this route start a new thread about using scripts. Or, of course, read the Wiki.

Hi Dave,

You’re right. I believe I did a while ago but that was manually through mission planner just like the photo showed, apart from the drone being visible since GPS is not being used. I will try to do this with the lua method. If both methods end up achieving the same goal, I’m not sure why it didn’t work when I did it manually.