Servers by jDrones

Takeoff - Auto Mode Fixed plane

Hi Everybody!
I´m working in a personal proyect, about a fixed plane using Pixhawk. It´s my first time using Arduplane, for setup. (my english is not good, so I will do my best to explain)
Yesterday was my first test and results were so goods. But, i had a trouble and i think that you can solve it…
My delta plane works perfectly in FWBA mode, but when i try to use it in Auto Mode ( with Mission Planner) , propeller turns on (TKOFF_THR_MINACC, TKOFF_THR_DELAY, TKOFF_THR_MINSPD params are not being read(?), and then, when aircraft has released of the bungee, the motor turn off. Im not using an air sensor. Is it important?

You can watch the messages of mission planner, params and log files in the next link:

https://drive.google.com/drive/folders/1uXUOGc5Kuws15mVZKm4T3PnmUOQ2rG9S?usp=sharing

Any idea about this?!
Greetings!

from a quick glance at the log your throttle channel’s RC setup.seems inverted. in your RC transmitter you seem to have high pwm at low stick position, likely by having channel inversion set, and likely tried to set that straight by inverting SERVO3 output instead of RC3 input in your flight controller. this works in manual throttle modes, but your flight controller’s throttle-demand to pwm relation is inverted.

check https://ardupilot.org/plane/docs/common-radio-control-calibration.html and mind your throttle bar moves accordingly to your transmitter stick throttle position.

plus you seem to have disabled the whole arming process by setting arming_required to 0. arming is a vital safety feature that should not be disabled. arming checks would likely have pointed you to a throttle setup issue before launch.

basti.

Hi @vierfuffzig!! Thank you very much for your answer. It helped me to solve the problem !!

Greetings from Argentina!!

np, hope you get things sorted and flying as expected, enjoy! greetings from hamburg.

Recently, I opened a Topic…
This is the link…

Can you help me with it?

Thanks!! Greetings!

Servers by jDrones