Take off and spin counterclockwise steadily and slowly in the air

The drone will rotate counterclockwise at the moment of take-off, and it will rotate counterclockwise steadily and slowly in the air.
I implore all professional pilots to answer, thank you very much

https://drive.google.com/drive/folders/1-kXmUqec9mh6J97McrbcyLCNnZ_SX1D-?usp=share_link

There is some motor output imbalance, but it doesnt look quite like a twisted motor mount or arm. Is it just a weight imbalance? That shouldnt matter too much as long as you are expecting it and OK with one or more of the motors working harder than the others.
Are all the props identical (except for the spin direction) ? Cheap props had a habit of being different between clockwise and counter clockwise.

It looks like Compass2 is not calibrated.
Since you had some yaw in that log I ran it through Magfit and this should fix up your compassess for now. Carefully put in these values, the names can be confusing
COMPASS_OFS_X 187
COMPASS_OFS_Y -156
COMPASS_OFS_Z -118
COMPASS_DIA_X 1.008
COMPASS_DIA_Y 1.041
COMPASS_DIA_Z 0.800
COMPASS_ODI_X -0.001
COMPASS_ODI_Y 0.005
COMPASS_ODI_Z -0.029
COMPASS_SCALE 1.00
COMPASS_OFS2_X -14
COMPASS_OFS2_Y 257
COMPASS_OFS2_Z 782
COMPASS_DIA2_X 0.995
COMPASS_DIA2_Y 1.037
COMPASS_DIA2_Z 0.800
COMPASS_ODI2_X -0.001
COMPASS_ODI2_Y 0.005
COMPASS_ODI2_Z 0.005
COMPASS_MOT2_X 0.923
COMPASS_MOT2_Y -2.897
COMPASS_MOT2_Z -4.547
COMPASS_SCALE2 1.00
COMPASS_MOTCT 2

Set
INS_ACCEL_FILTER,10
and connect to MissionPlanner Initial Parameters section and put in you prop size and battery cells, accept everything it offers including the battery failsafe actions.

Also set these for the next steps in tuning the Harmonic Notch Filter
INS_HNTCH_ENABLE,1
INS_LOG_BAT_MASK,7

Thank you very much, today I tried to change the version from 4.3.0 back to 4.0.7, the spin problem did not happen, I don’t know if it is because of the version problem.

I would stay with latest stable version and fix the actual problem. Something in the earlier version may be masking the problem (not fixing it)

You still have to do the same things I mentioned for any version

Ok, I’ll keep trying 4.3.0, i wonder what argument do u usually used for magfit, cuz my value is quite different from yours. Thank you!

I choose mag0 and mag1 in turn (dependent on installed compasses), and Elliptical and CMOT
For a small log I dont worry about setting the “reduce” amount.

I’ll run it again and see if I get the same - maybe I missed some option earlier

1 Like

I ran it again and got the same values (with some slight difference to mag0 since I probably forgot to pick Elliptical and CMOT last time) but these should be safe to use.

COMPASS_OFS_X 187
COMPASS_OFS_Y -155
COMPASS_OFS_Z -114
COMPASS_DIA_X 1.008
COMPASS_DIA_Y 1.043
COMPASS_DIA_Z 0.800
COMPASS_ODI_X -0.003
COMPASS_ODI_Y 0.003
COMPASS_ODI_Z -0.025
COMPASS_MOT_X 0.055
COMPASS_MOT_Y -0.097
COMPASS_MOT_Z -0.149
COMPASS_SCALE 1.00
COMPASS_OFS2_X -14
COMPASS_OFS2_Y 257
COMPASS_OFS2_Z 782
COMPASS_DIA2_X 0.995
COMPASS_DIA2_Y 1.037
COMPASS_DIA2_Z 0.800
COMPASS_ODI2_X -0.001
COMPASS_ODI2_Y 0.005
COMPASS_ODI2_Z 0.005
COMPASS_MOT2_X 0.923
COMPASS_MOT2_Y -2.897
COMPASS_MOT2_Z -4.547
COMPASS_SCALE2 1.00
COMPASS_MOTCT 2