T-Motors BLHeli_32

Hello gents. I"m new to this and building a Y6 drone. I have a problem that’s been driving me nuts for a while.
Im running a Pixhawk 2.1 (cube), TMotors FPV 35A-32bit with Tarot 5008-KV340 and 18x5.5 Props and using APM Copter 3.5.5.

all up ESC calibration failed so I had to do each one of them manually and can’t flash ESCs with BLHeliSuite 32 because its not supported yet (I think). When I do a throttle test, all 6 motors work but only generate 10% thrust.

Does anyone have any suggestions?

Great timing!

When did dshot support get added to copter? That’s a pretty big deal, and I just read a post from someone saying it’s not supported yet, just about a week ago.

It was only merged into master within the last week (was in a development branch before that). It’s been successfully flown in a number of aircraft, but should be considered under test until it’s in a stable release. The wiki page only went up today.


Hmmm am I blind here.
The Arducopter V3.6.0-rc1 Y6 just showed up as a beta but the SERVO_BLH_AUTO param does not show up on the list. Neither is the DShot protocol in the ESC section

I built a hexacopter with PixHawk 2.1… T-Motor MN4014 330KV motors… 18x5.5 ich props… with T-motor Air 40A ESC… The Air 40A worked for me with calibrating one by one, and also worked by calibrating them with Mission Planner.

Ok this is starting to drive me nuts.
I upgraded to Arducopter V3.6.0-rc2 I am stil getting the same problem. I measured a single motor. When I go to full power it consumes 0.7 amps of power instead of 21 Amps and only generates about 400 grams of thrust instead of 3kg. All 6 motors seem to top out at 10% of Max thrust.

I can’t get into BLHeliSuite 32 because the SERVO_BLH_AUTO is not present on the firmware currently available. I think its only the beta running ChibiOS.

I have never been able to flash the ESCs, any chance they come pre programmed for a max thrust of 10% from the factory and you have to flash them? I’m out of ideas, been at this for 3 months.

Thanks for any help.

What a stragne treat nowhere does it say adam is using d-shot, and if he was non of these problems would be possible…

Adam, i think you’re right about the “beta running ChibiOS”. What “MOT_PWM_TYPE” do you use?

I don’t calibrate my esc’s. I know there is a small difference possible per esc because the analogue way the signal is measured, but i don’t care… (i use "MOT_PWM_TYPE: 2 right now)

My suggestion is: buy an arduino nano, hook it up to BL-Heli suite and turn it into a programmer (4-way-interface Multi). Then connect all esc’s to it (signal and a common ground).
(Or you can use fw3.6 with chibios)

In BL-Heli suite I put “PPM Min throttle” to 1040 and “Max” to 2000.
in arducopter:

If you’re using Dshot calibration is not needed! And Mot_pwm min and max are meaningless.

Thanks I will double check the numbers.
Oh yes sorry I forgot to include it. Yes I am using DShot 150

D-shot does not need to be calibrated, this is impossible!

Both arducopter and blheli will ignore any calibration or min/max pwm values if you’re using Dshot.

Had to put this aside for a bit.
So I took the whole drone apart and pulled out a single motor and ESC and set them up on a bench.
Completely removed the Pixhawk 2.1 Cube out of the equation and hooked up the PWM from the Frsky X8R to the T-Motor 35A FPV ESC directly.
I am getting the same problem as before. Motors go to maybe 10% of max thrust and the throttle is only effective for the first 1/4 of travel on the Transmitter, the upper 3/4 does not increase speed of the motor.

Have you tried to do a calibration in the Motor, ESC, X8R configuration?

Hi Helmet. Yes I tried the single ESC manual calibration and I get very different beeps than everyone else.
Entering calibration I get 3 beeps and the melody
at 100% throttle I get nothing
at 0% throttle I get 10 beeps and the melody.

And to make matters worse, after trying this 4 or 5 times. Looks like I fried the ESC, great lol

Was there a solution to this? I’m having the same issue

Hi Mark. No I did not. Give me 2 days to properly reply to this email…in the middle of a crazy work stretch.


The solution could be as simple as turning off “Low RPM Power Protect” in the BLHeli settings…

Hi Mark.

This problem has been driving me nuts for a while. I looked at the logs and it does show the RC_In and RC_Out showing 2,000 PWM at full power.

So the Pixhawk cube is receiving command from the controller to go to 100% Thrust and is passing it on to the ESCs.

I even bought a different ESC and completely disconnected the Pixhawk thinking it maybe the Arducopter OS but still the same problem.

It goes up to 5 or 10% and that is it. Where each motor should be generating 3.5kg of thrust I get 0.3kg.

This Low RPM Power Protect may be the issue. I"m gonna try it, just have to put the whole drone back together again.

Any news on your front?

This has turned into a commonly reported problem. Most of these ESC have low rpm power protect turned on by default. No problem with the target market with relatively high kV motors but its not suited to low kV motors.

Just tested it. Yup that is the problem.

Was trying to figure it out for a year.

I have the same exact problem with T motor F45A ESC. But in my case turning off “Low RPM Protect” did not solve the problem. Could it be a motor timing issue?