T-motor Flame 200A ESC with Pixhawk cube orange problem

Hi,
I am using t-motor Flame 200A ECS with my pixhawk cube orange. I have used other t-motor ESCs earlier but never encountered this problem.
The Problem- There are Two set of servo connectors with 3 wire each. I know that the signal and ground wire are supposed to be connected to pixhawk’s main out just to spin the motors(ESC servo connector has white,red,black wire) but they are not working. The ESC is flashing red LED and motors are emitting the beep tone upon connection.
What is working- I used all three wire in the servo connector and tried it to give the signal using flysky receiver’s channel 3. Upon powering up the setup the ESC stopped flashing led and the motor beep sound stopped, when throttle is raised the motor is spinning.

what could be the solution - what can be the problem here? Does this particular ESC requires some extra efforts to make it work with pixhawk?
Please see that i have tried other pixhawk boards as well, pixhawk is not the problem here(there must be something that i am missing here, please help me make it work)
Thank you.

I suppose you have already performed the RC radio and ESC calibrations?

The thing is on arming or on motor testing beeping doesn’t go away. Pixhawk is sending signals and i can see arming on mission planner but motors don’t spin.

Have you tried this:

I got the solution to it. The parameters did not solve the problem because it was never a signal issue.
Actually I was able to run the esc-motor using RC’s receiver because it provides 5V at the middle wire which was powering up some circuit inside the ESC. I had to provide external 5V to the middle pin of ESC while ground and signal wire were connected to pixhawk (as pixhawk do not provide 5V out on servo rail).
SOLUTION Provide external 5V to the Middle pin (red wire) of servo connector coming out from ESC.

Can I somehow safely provide 5V to pixhawk MAIN OUT middle pins just to avoid additional circuitry for providing 5V?

Nice, glad you could solve it!
I have not used the standard carrier board for some time now, but as far as I can remember it is safe to just inject 5V from an external 5V regulator on to the servo rail (MAIN OUT pins).

Actually, I would like to open this discussion again, Things are still not working.

Any suggestions from anyone?

Have you got some pictures of it all wired up?
Are you using ONLY mission planner motor test for testing?

Set BRD SAFETY ENABLE to 0 to disable the external (un)safety switch

It sounded like you solved it last time by powering the ESC separately, is this solution not working anymore or is the issue slightly different now?

The Flames don’t need 5v supplied, just PWM and signal ground.

Yes, you are right the one that I have that is flame 200A does require an external 5 Volt.

Are you using MissionPlanner motor test?
Got a photo of your wiring?
Parameters?

I thought i did, but one motor setup worked and when i tried 8 motors all at once then things didn’t workout.
It’s working with holybro pixhawk 6c (in this case all 8 motors are working)
But same scenario is not working with cube orange.

Yes, i used mission planner for motor test.
Parameters and wiring i will share it with you, give me some time.