T-Motor 45A 2-6S V2 4in1 connected to PIXHAWK 2.4.8

You could. Or just leave it configured as is.

Telemetry work?

ok , so how would I check if the telemetry works

Is it connected to a serial port and configured?

yes , i have it connected to serial port 5 RX pin and in the params, set SERIAL5 set to 16

OK, then you need to run the motors and collect a flight log and see if there are ESC fields recorded. You could try using Motor Test and set it to run for a minute or so then monitor ESC RPM from the Tuning Screen.

so if I do this how fast will the motors spin while doing the motor testing

You can set the throttle percent.

Ok so i washaving a wiring issue but I’ve straightened that out . Now I’ve got 4.1 DEV on the Pixhawk and parameters set for BL Heli pass through the T-motor 45A v2 4in 1 ESc to the Servo 9-12 on Pixhawk , this is the screen shot of BLHeli suite , for some reason only the Master ESC #1 shows Input Protocol : Oneshot24 and I have it set to DS600, I have tried different DS 150 , 300,600,1200 still the same

I’m not sure what to do next

Hmm running out of ideas. Andy @andyp1per what do you think?

I know what you mean , it’s confusing. It doesn’t matter which protocol I have set ,oneshot, Dshot it always shows OneShot 24, and most of the time it’s only the Master ESC #1 that shows Input Protocol: OneShot24 the rest say Unknown. Should I try to calibrate the ESC in Mission Planner even though all the ESC’s don’t show the same Protocol. Or should I just use it in PWM mode instead of BLHeli 32.

just a little more info on the drone I’m building ,my first. It’s frame size is 510mm so , do you think the ESC I’m using is appropriate, in the ESC instructions it says typical application : 170-450 mm , is my 510 mm too big for the ESC

No. 4in1’s are generally targeted towards smaller racers but it doesn’t matter as long as the Voltage and current rating is sufficient. About the only thing you usually have to do is turn off Low RPM Power Protect as it’s often on by by default for higher kV motors. But I see it’s off with yours anyway.

I don’t know what sense OneShot24 makes. That’s no protocol that I’m aware of.

Dave do you think I should try and calibrate the ESC in Mission Planner even though the input protocol is erratic , or should I go back to PWM mode and go forward from there.

If it’s not recognizing Dshot I would configure for PWM, or Oneshot125, and then calibrate either thru Mission planner or the All At Once method with the Transmitter.

One last thing you can try is increasing the SERVO_DSHOT_RATE. Leave it at Dshot 600 and incrementally increase this and see what happens with passthru. I don’t have experience with this but there are some posts on the forum here where it’s described.

I tried at Dshot 600 and increasing the SERVO_DSHOT_RATE incrementally from 0-10 it didn’t really change anything , still unknown protocol . I also tried SERVO_DSHOT_ESC set to 1 ,but didn’t change anything either.

Do you have SERVO_BLH_AUTO = 1?

Likely this is a timing issue like all the rest, but I’m unlikely to have time to investigate.

hi andy , Yes SERVO_BLH_AUTO is set to one. It’s been confusing because I can connect to the ESC via BLHeli suite and flash the latest firmware 32.8 , manipulate all the settings in BLHeli Suite, When I read the ESC , it usually says Input Protocol : UnknownInformationFoundMultipleESCcon_210519_1
2021-06-03 11:02:30 AM : u-blox 1 HW: 00080000 SW: ROM CORE 3.01 (107888)
2021-06-03 11:02:20 AM : Frame: QUAD/V
2021-06-03 11:02:20 AM : IMU0: fast sampling enabled 8.0kHz/1.0kHz
2021-06-03 11:02:20 AM : RCOut: PWM:1-8 DS600:9-12
2021-06-03 11:02:20 AM : fmuv3 00430037 52565017 2036394B
2021-06-03 11:02:20 AM : ChibiOS: 08877972
2021-06-03 11:02:20 AM : ArduCopter V4.1.0-dev (8925c283)
Here’s some

Did you get this sorted? I’m having the same issue. Except all esc’s are showing the protocol as oneshoe24 (set to Dshot600). Motors arm and spin, but that it’s. The esc’s don’t understand anything beyond spin slow lol.

Hi Shaun , yes I did figure it out. In the Parameter’s when using analog motor outputs the Servo_1 to servo_4 are set to the Motor outputs 33 to 36 , when using the Digital outputs for Dshot Servo_9 to Servo_12 need to be set to the Motor outputs 33 to 36, good so far, after setting these you need to go back to Servo_1 to Servo_4 and set these to 0/disabled. Once you’ve done that it should register the correct Protocol .
Merry Christmas !

Strange, I’ve got my servo 9-12 set to motors 33-36 already. Oh well, that oneshot24 must be the new thing lol. Because it flies really well!