Support for Old Boards

Hi Gents

I have been given a DIYDrones APM 2.0 board which appears to work with APM 2.0.20. However, I can load the firmware and then nothing . . .

Documentation for this board to allow troubleshooting appears to be near non-existent.

Anyone got links?

Many thanks in advance.

This is all that is available in the APM hardware archive and it does not include the 2.0.

The board should still work.
Thanks, Grant.

Many thanks for that, Thomas. It’s a great resource, but 5 year old boards is too old for an archive? No wonder the historians are worried about our digital age : )

HI Grant. It doesn’t.

There appears to be a problem with the barometric sensor. I have seen one post where someone commented that there is a thread in the software that checks the values for that sensor and if there is a fault there, then the rest of the processes fail.

I can upload a firmware, but APM 2.0.20 (or any other version I have tried) cannot get any data back from the board after that.


APM v2.50 will work on a 2.0 board - I have one on my desk and it works.
How do you know there is a problem with the Baro? You need to ensure the baro is covered from sun-light as that can cause problems.
How are you loading the firmware? Via Mission Planner?
Thanks, Grant.

Hi Grant.

Thanks for thinking of me! I have had similar results using APM 2.x using my Dell laptop and my iMac:

I can load a firmware (tried both rover and plane).

However cannot achieve communication after that ( short of reloading the firmware ).

The clue about the barometer comes from the console when trying to link the board. There comes a message ( from my memory ) that there is an error in chip bms ???

Thanks again. The board is ready for the bin but if it can be used, I have an old Tamiya Rock crawler chassis for it.

Andrew Jackson