Stuck in Standby mode?

My copter won’t seem to get out of standby mode, and I’m not sure how to fix/change that. I have the breathing blue light in the shop, and the breathing green outside (with GPS). The arming button gives one of two responses: tripple, rising beep (buh duh dum), or double, constant beep (duh duh), with a purple/white LED indication.


I think it wpuld be helpfull if you shared what configuration you are using, i.e. which components, which flight controller, which firmware etc.

Maybe also a pic or a short video that shows what are observing.

As a shot into the dark - I get the double-beep when I try to arm but have not pressed the safety switch before (the duh duh is an indication that safety has not been removed yet).

How ar you trying to arm the copter? You mention thr “arm-button” - I am not sure what you mean with that?

We’re using a 3DR X8 drone with the PX4 flight controller, and the latest firmware QGroundControl gave my copter (not exactly sure which that is). And yes, I misspoke when I said ‘trying to arm’, I meant ‘holding the safety switch’. I also tried having the manual controller linked and powered on for this process, still with no luck.

I will also attach a short video of the copter if this information is not enough at my next availability.


To get the motors moving there are two things you need to do:

  1. Press the safety switch (long) until the flashing light on the safety switch stops blinking and it shines permanently. When this happens, at least for me, the ESCs calibrate, which causes a three tone beep sequency, also the motors twitch ever so lightly at that moment.

  2. Once safety is lifted (is there to prevent accidental arming) you need to actually arm the copter (i.e. change it from standby into flight mode). How to do this depends on your RC configuration. In my case I have set it up in a way that on the remote control I pull the throttle stick down and left hard and hold it there for a few secs until there is one long beep. At that point in time, depending on the config, the motors can already start spinning slowly, but must now.

Once armed moving the throttle stick up increases rotation speed until it spins fast enough to generate lift of thrust.

Not sure if this helps, but that is my start sequency…


that was the response I wasn’t getting when holding the safety switch, it just beeps twice and flashes and doesn’t arm. I had the copter working last week, but after a firmware update (not my current one), I lost that progress.

When I say ‘standby mode’ I don’t mean the double-flashing blue or green LED, I mean the breathing LED indication, as described on, where it makes the distinction. It is NOT performing any of the actions described in this video, which I know is a popular guide for LED and sound meanings:

I don’t think I have come across the “breathing” LED situation… so not sure.

Are you saying that the when you press the safety switch (long, > 3 secs) the blinking of the safety switch LED does not stop?

The copter can only arm once the blinking has stopped…


Yes, that is the problem I’ve been having

Mission Planner’s HUD and the TLOGs will tell you what the prearm failures and arming failure messages are. You’re randomly guessing without it.

Breathing LED means PX4 firmware stack, right? Never seen a breathing light with ArduPilot, only flashing. Is the switch behavior the same with PX4 as with ArduPilot?

Thanks, everybody. I got it working, although my LED continues to breathe instead of blinking. I just did a full, hard reset on my ground control machine and the PX4 itself after waiting a day. Still not totally sure what the issue is, but unplug and plug something back in and miracles do happen. :slight_smile: