Strange Throttle output : Version: 3.6.7

Ed, I took one look at your params and you are NOT on version 3.6.7. You have 3.5.7 in that thing. I would suggest loading the latest stable firmware in it, which is 3.6.7. You can do that with either Mission Planner or QGC. But I would suggest using QGroundControl as it makes the setup pretty much trivial compared to Mission Planner.


A big big thank you for helping—- and it makes sense!

The last bit explains a lot. So, in Ardupilot it is servo6 function that mixes to servo3 function. And this goes through channel 8 as a throttle lock.

MP Heli setup screen, on far right, has option, Ch8 or thr curv. But, the point below where one would input the values for throttle curve are greyed out. Will your setup explanation open the greyed out spaces for setting the values?

I will update to you when I have tried your changes.


Unfortunately, the heli setup in MP is broken and does not work. And Bill and I are not able to fix it. Do not use that. We have had a request made to remove that page for over a year and it never got done.

The heli setup in QGroundControl does work and will not make bad random settings to your helicopter that will crash it. If you load the latest firmware the heli setup in QGC looks like this and it has the throttle curve settings.

You are correct, it has V3.5.7.
In MP I tried to upgrade to 3.6.7 but MP says that it is already loaded?
QGC reports it is 3.5.7 and wants upgrade to 3.6.7. I tried to get it to do the update. All I get is update cancelled.

@ChrisOlson could that be a nuttx to Chibios issue? @aerocar the underlying OS changed from 3.5 to 3.6. you maybe seeing an issue with updating to firmware with new OS. I will have try to find out how to overcome this problem.

It shouldn’t be a problem. Ed, try this link to download the firmware for your board to your PC. There is not a .bin file there that QGC will recognize so that is the .apj file that Mission Planner should know about.

In MP where you load firmware there is a link that says to load custom firmware. Click on that and it should let you browse to where you downloaded that firmware file and try to install it manually.

It is possible MP is just not recognizing the board and this process should bypass the automatic detection of the board.

Chris, I clicked on the file. It appears in Windows EDGE browser. I can select all, but how do I save it as a file? I know computers pretty well, but this stumps me. Or am I to send MP to the link?

I suppose Windows does things different. It is in the ArduPilot firmware repository. Try this link instead and see if you can download the apj file there for the mini pix

OK, finally got it loaded.
is this a generic 3.6.7 Heli file?
Do I now load my parameters?

Yeah, it is the standard heli firmware for the mini pix. So now you need to set the heli up from scratch, level the swashplate, set servo limits, pitch limits, etc, etc…

If you have save parameters and you know they are good, you can use those. But double check everything because one wrong setting can be bad.

I did that. Now the swashplate, tail, collective all work. But, not motor.
I did find that if I reverse servo6 the motor spins up. (It is not the actual motor in the heli but one strapped beside it and connected to the ESC) I switch the servo6 back to normal and the motor stops.
Although I am inside, the GPS gets lots of satellites and we have a fix. But, the green light never goes solid green.
MP says “disarmed”.

When calibrating the compass system, it is not explained that we have both a compass in the Minipix and in the GPS. both are mounted with arrows facing rearward. When I do the calibration, QGC talks saying that the compasses are inconsistent. I do not find the place in parameters to tell that both are yaw 180.

with the compass 1, enabled or not. Compass calibration always fails. It gets up to 99%, then back to 0%. With previous version firmware, no problem.
Still, no throttle response.

Unfortunate new problem. apparently compass is not healthy. With either MP or QGC I can not calibrate compass.
Is there one compass? In GPS or in Minipix or both.
Without a calibrated compass, I can not test motor.

Ed, it is recommended to disable the internal compass on the board, and only use the one in the GPS module (external).

Also, attempting calibration around any sort of metallic objects, or inside, is not recommended. Do this outside away from any sources of magnetic interference to get good offsets. Even being within 10 feet of a car will affect the earth’s magnetic field. It is more than just a “compass”. It is a three-axis magnetometer that actually measures the earth’s magnetic field.

Compass calibration - 99% ?

Look at this Link:

Again, Chris, thanks for so much help.
The deeper I get into this MiniPix/Ardupilot programming the more I appreciate its ability and sophistication. It is a real learning experience.
On my Heli, MiniPix and GPS/compass face aft. MP says that if they face same direction, no need to label direction? You advise enable only one for calibration. So, MiniPix internal compass 1 would be a 0 , not enabled. Then GPS/ compass will be yaw180 enabled.
I am inclined to reload V3.6.7 and start all over with orientations and RC done first. Ed

Yeah, the AHRS orientation should be set to yaw 180. Same for the compass. Disable internal like you say. I think 3.6.7 auto detects the mag orientation and sets it for you though.

I am getting the message “Compass faulty” .
I downloaded MP from Ardupilot. It is much newer that MP from Radiolink.
Swapped GPS/Compass with one in JCZK helicopter. Swap worked fine in both.
With Arducopter MP (AMP) got compass calibration following your advice, use only Compass 2 external.

Using new AMP is has, under “mandatory” a section “servos”. It does NOT show servo6 following throttle stick, but does show servo3 moving collective pitch.
But, now that a compass works, when armed flight motor (substitute) responds to throttle stick.
OMG!! Everything works.

1 Like