Compass calibration stuck at 99%

Hello there,
When I try to make the compass calibration I press start and rotate pixhawk and calibration stucks at 99% all the time(calibration mode). I am using latest arducpoter firmware and mission planner. Is this kind an hardware issue?



Where do you do it? Do it outside far from magnetic interference.

I have the same issue

I do it in an underground lab. Only few wireless modems around here. Thanks

same issue

I did it on QGC and it completes fine.

Have you tried the old way with the MissionPlaner compass calib?
I did that ones and repeated after that with the new method and it worked.
To get the MP version to work: hold down control while clicking compass on the left hand menu.

I didnt understand the old method. Could you explain more clearly please? Thanks

The present Method is the onboard compass calibration controlled by the firmware. The old Method is still in Mission Planer but you have to call it in by hold down control while clicking compass on the left hand menu. That method is controlled by Mission Planner and should work each time.
It looks to me after values written to the AP the on board method is than willing to start too.
Don’t ask me why. It is just what I have experienced.
In the future we have a in flight compass calibration. It has already been tested and it seems to work.
It happen to me to both 2 new HERE GPS-units. Both did not finish the onboard compass calib.
After going through the old method first it worked with both later the onboard as well.