Stock 3DR Solo autonomous missions with photos

I have access to use a stock 3DR Solo and need to fly autonomous missions with photos (for photogrammetry). I do not have permission to change the cube, and can only do firmware updates if there is an option to restore the previous firmware. So I’m working with the Solo version of ArduCopter (~v3.3). I’ve been able to run autonomous missions using QGroundControl (without any firmware upgrade) but not successful at triggering photos (GoPro Hero 4 Black) during the mission.

Any tips for flying autonomous missions with photo collection on a stock Solo? Any suggestions about how to deal with compatibility–including older versions of QGroundControl or Mission Planner that might work better, or might ArduCopter 3.4 work better and be safe while not requiring the Green Cube?

@Pedals2Paddles is the Solo maintainer and probably best placed for Solo support

1 Like

Although I never tried this with any of my Solo’s I was under the impression that a Solo with a Hero 4 would have the camera triggered if running a survey grid on Mission Planner

1 Like

Yep. If you have a hero 4 black in there, the mission camera trigger will trigger the GoPro. So I suspect you’re using a lesser GoPro or not configuring the mission correctly?

The stock firmware has customizations to address an ESC issue. No other stable release versions of ArduCopter have that. It was recently introduced into master (3.7-dev) to allow Solos to operate safely on 3.7 when it is released. But there are still some issues to be worked out and I wouldn’t use it on a customer vehicle.

Thanks. Is that true for Qgroundcontrol as well as Mission Planner? Any tips on how to figure out what might be wrong with our settings?

ArduCopter mission commands are the same regardless of GCS. What mission command are you using to take the pictures?

We have tried both the Survey and Waypoint type of missions in Qgroundcontrol. It looks like we have selected Take Photo at waypoints, but then if we upload and download the mission from the Solo, it resets the drop down at waypoints to No change (from Take Photo).

Any new developments here? I’m currently running into the exact same problem. GoProHero4 (silver) + 3dr Solo setting up autonomous routes with QGroundControl. The drone follows the route with no apparent problems, but the GoPro isn’t taking any photos.

Yes, first make sure that your communication settings are set to MavLink in QGC. Then add a waypoint before your survey that triggers Take Photos (Distance) and specify the distance spacing you want between photos. In our case that worked and the survey setting for %overlap would change the trigger distance to what it should be for the survey.


Thanks for responding so quickly. Following your recommendations I was able to get the Solo to complete a full survey with photos!

@Pedals2Paddles Do you mean that there are issues in terms of features / full support or in terms of safety? Is there a rough ETA for an official release if safety is a concern for now? I have two Iris+ at the moment and am planning to expand the fleet, I imagine the Solo would be an upgrade (would it ?) but since I plan on buying several more drones, having to spend the extra money for upgraded cubes on each is a bummer.