Stabilize Mode for initial testing

I need to set my flight mode for initial testing. My goal is simply to make sure the drone hovers and responds to RC input. I am not looking for performance testing.

Currently when I arm, the motors spin. As i increase throttle, maybe two clicks on controller, the motors seem to spin up faster from 1 to 2 then from arm to 1. I am not sure if this is a function of flight mode, or some hover auto learn I am reading about.

My goal (to be specific) is to have the throttle spin up as slowly as possible to test the motors and esc in flight. I want to go from just under hover throttle to right at hover / lift-off throttle…if possible. I don’t want it to throttle up and bolt away.

Thoughts / insight?

Stabilize mode is what you want. Then AltHold then Loiter when ready to test other modes.
Ifvibrations are low and there’s no other problems you can use AltHold and more. Always be prepared to switch back to Stablize.

Thanks! Any advice on how to control the initial throttle after arming? Like I mentioned, it seems like it throttles up disproportionately after arming.

The throttle-up can be savage but check MOT_SPIN_ARM and MOT_SPIN_MIN
Provide a .bin log file and we can see what is going on.

Also if you have a spring-centered throtte stick (probably preferable for multirotors anyway) then also set this:

How exactly do I pull/display the log file you are asking for? I am in Mission Planner (latest version). I downloaded my log from yesterday. Here is where I am at.

Here is the auto-analyze from the log file.

***Despite the disproportionate motor spin after arming, the log above shows I never even reached 20% output. Also, the power to each motor looks good / balanced. I don’t see any immediate issues if I increase throttle.

***Hover is set to learn and save.

***I was not able to find / change the BHV setting.

***Motor_Spn_Arm is set to 8% which is 2% above deadzone.

***Motor_Spin_Min on the same motor test page appears to be stuck at 3%. I can’t change it.

You downloaded the “dataflash” .bin log file via MissionPlanner already and it was saved in a logs directory. Now you just need to upload that .bin log file to some file sharing service like dropbox, and copy/paste the public link to your file here.

Here is what I have from yesterday…



A few things I spot right away:

Definitely set these to 0 right away - instead they are defined in the RCMAP params

You’ll want to set these, and channel 5 is normal for flight modes
The flight modes you will need for testing and learning will be 0 (Stabilize) 2 (AltHold) and 5 (Loiter)
You can find them and set them in MissionPlanner flight modes screen, move your flight mode switch (channel 5) to verify what happens, you’ll see the PWM reported and the highlighted mode should shift.

Your current monitoring is not working but is not critical at this stage.
Voltage monitoring seems OK but there’s a few more parameters you need to set in relation to that.
Connect to MissionPlanner and press Alt A and step through that dialogue, you should be able to just put in your actual prop size and battery cell count then accept everything else it offers. At the end let it save every parameter it calculated.
Also set these:

Now assuming you’ve done the RC calibration (and all previous steps) then do the semi automatic ESC calibration.

Then test in MissionPlanner motor test before trying to fly. Look for correct order (A, B, C, D) and direction of rotation
The arducopter numbering is changed to letters and a different order in MP motor test
so pressing the “Test Motor B” button will spin actual motor 4

Your MOT_SPIN values looked OK already, you probably dont need to change them.

If you are stuck on something or have any doubts at all go through the doco (it can take days/weeks/months) and search in the forum.
Let’s see how all that goes and you can post updates and more questions in here.

1 Like

All mods made and everything calibrated. What effect would the RC2 and RC3 set to stabilize have? Were flight characteristics altered when I throttled up? Also, do I need to worry about th3 BHV settings?

PILOT_THR_BHV,7 is not essential but it helps if you’ve got a spring-centered throttle stick.