SRXL2(?) Qgroundcontrol + Mission Planner + general strangeness

As might be clear from the title, I’m not sure what is causing my issue. I have a Pixhawk 2.4.8 FMUv2 (no 1MB issue) and I am using new Spektrum 4651T receiver. The receiver is configured according to Arduplane docs on serial 4. (A few years ago I had an AR610 receiver with a ppm sum encoder but when I powered that up this year it didn’t feel like working). I am having issues with my radio working.

In QGroundControl: The switches on my radio work fine but none of the axes move.

In Mission Planner (and with no GCS connected): Axes move if the throttle is raised above 0 but are stuck centered/frozen if the throttle is at 0. Switches work fine.

Transmitter is a Spektrum DX6G3 with the latest firmware.

It looked to me like the copter changelog differed somewhat wrt SRXL2 but testing flashing copter and reconfiguring has not fixed this for me. Behavior is exactly the same.

Anyone got any ideas? Thanks

Can you post your settings and a brief description of how this is wired up

Hi Andy, thanks for the reply!
I have reset all parameters and then configured my elevon plane and the receiver as follows:

  • SERIAL4_BAUD = 115
  • RSSI_TYPE = 3

I have it wired as described here: Spektrum RC Systems — Copter documentation
I cut up the SRXL2 and TELEM wires and connected VCC-VCC, GND-GND, SIGNAL-TX on SERIAL4. I have also tried this on TELEM2 (SERIAL2).

I have also tried different baud rates and locking the RC_PROTOCOL to 256 (SRXL2) but this doesn’t change anything. SR4_RC_CHAN is > 0.

One thing to check is that you are supplying enough juice - these RX’s are pretty hungry. Not sure what the output on serial4 is but I’m pretty sure serial1 will provide more

Same issue on serial 1 unfortunately

With some more testing I think this might be a qgroundcontrol issue. I changed the travel limits for throttle and everything works in mission planner or without GCS now. Issue is still as described in qgc.

Seems like QGC issue caused by this: Radio channels 1-4 dead after connecting to QGC under Linux · Issue #6370 · mavlink/qgroundcontrol · GitHub (disable virtual joystick to get channels 1-4 back). I’m all set now - no issues with Spektrum or Ardupilot! Hopefully this can help someone else.