Spektrum Satellite Doesn't Bind on PixRacer

The Spectrum Bind in Mission Planner and QGroundControl doesn’t work with PixRacer and any flavor of Arducopter firmware. It is clearly a firmware issue as the latest PX4 firmware will put the Spektrum satellite in bind mode via QGround Control. You can see on a logic analyzer that the bind signal (7 low pulses) is not sent to the receiver when toggled from Mission Planner and QGroundControl with Arducopter 3.x installed. I’ve tried the beta and master versions as well. Please fix.

Ok, thanks for the report. I don’t personally have a spektrum tx/rx but hopefully we can find someone in the dev team who does.

This still hasn’t been fixed FYI.

Still not working more than two years after this post…

It seems I have the same issue with a slightly different setup. It works beautifully with PX4, but not with Ardupilot. My setup:

Lemon DSMX Rx
QGroundcontrol 3.5.5 (Mac)
Arduplane 4.0.1

When I hit ok in the Spectrum Bind dialog (top right in QGC) the dialog disappears and nothing happens.