Speedybee f4v3 ESC problem


I’m new to Ardupilot but not new to other firmwares such as iNav. I have successfully flashed my Speedybee F4v3. Instead of the stack, i’m communicating with 4 “normal” ESC’s. I am unable to get past the calibration step of the ESC (which I’ve done many times before in other firmware). i’ve tried changing the frame rate to 50

  1. When i plug the battery in, i hear the 3 beep power startup tones of the ESC, but not the 2 beep throttle confirmation from the FC.
  2. When i first plug in the USB, turn on my transmitter so the receiver goes online, and then the battery, I got the 3 beep + 2 beep throttle confirmation and the ESCs beep steadily as if they are waiting for calibration (but i can’t do anything really)

So I can’t calibrate, and the ESC’s don’t seem to be getting throttle confirmation (all of them, not just one of the 4), where I know I can flash inav and it’ll work…

Did I miss something obvious? Thank you.

Do the motors spin when using Mission Planners Motor Test? This would be a step before you got to ESC calibration.

yes, that works, motors work from mission planner. ok, i got it to the point where i can arm and control the drone motors via throttle, as long as i have the USB plugged in first before i plug in the battery. all of it seems to work. except… obviously, having the usb plugged in doesn’t make sense and isn’t useful… i can unplug the usb after the fact and it continues to work. if i disconnect the battery next and reconnect w/o usb in the FC, then i don’t get the throttle confirmation back to square 1.

just to repeat the test, i can just plug in USB, don’t have to connect mission planner, plug in battery, and it all works (haven’t tested with props, but i can get it to arm and spin via the controller. If i plug in only the battery w/o the usb, no thorttle response beeps after power up beeps from my escs, and it doesn’t work.

also i do have arming checks disabled right now.

I would be surprised if the ESCs you are using don’t support dshot - use that and you wont have to calibrate

they don’t. :slight_smile: this is a bit of a franken-build w/ left over parts. they are just analog 30a esc’s. 4 individual ones.

1 Like

also, i reflashed to inav to test to make sure nothing strange happened physically. it’s fine, functions like it should under inav. did an esc calibration and it worked like I expected it to.