SpeedyBee F405 Wing NO ESC TELEMETRY

The ESC Telemetry is not work in this AP. I am using the latest version of Plane 4.4.4. The ESC is working on other APs but not in the SpeedyBee F405 Wing. Also tried on another SpeedyBee F405 and same issue.
I am using the Serial1 but also try on other Serial ports without success.
The ESC is working, the motor is running properly, I can command the reverse mode, can connect to the BLHeliSuite change settings, etc. but no Telemetry is available.

Can someone confirm this feature is working?
@tridge there must be a bug here!

From a parameter standpoint it looks good and I can’t find anything ESC telemetry related in the 405 WING docu.

I thought about mentioning the SERVO_DSHOT_ESC,0 in your parameters but since the telemetry request bit isn’t technically a DShot command it shouldn’t make a difference.

I also thought about suggesting to try bi-directional DShot but according to this website bi-directional DShot only works with DShot300 and higher. You are using DShot150 atm (SERVO_BLH_OTYPE,4).

I have it running also with DSHOT600 but without Telemetry.
Seems that BDSHOT was disabled in this AP.

I just want someone to confirm if the ESC Telemetry feature is available or not for this AP.

Yes its available, only bdshot is not available

To which Uart you connect the ESC telemetry and just for reference which ESC brand you use?

UART5. Brand should be immaterial.

Thank you. Do you have a way to confirm on Serial1 or Serial4 ?
I have with me 2 stacks SpeedyBee F405 Wing and 2 Holybro Tekko F4 BLHeli32.
Both ESCs they do work on the MateKH743, but not workin on either the SpeedbyBee F405 Wing! The hardware connection is very simple,and I am very familiar with this setup, the telemetry should be working, this is strong evidence that something is wrong. I need your support please.
I am going to check the Serial5 and give you feedback asap. Thank you

Just check the Serial3 and Serial5 and unfortunately it’s not working! So it’s not working in any Uart from this AP. If we connect this ESC in the Mateksys H743 Wing then it’s working. There must be a bug in the FW for certain!

The ESC is sending the Telemetry I can also confirm the signal in the oscilloscope:

Sorry, I didn’t know this was the wing. @hwurzburg has disabled ESC telemetry in the wing - you should ask him to change that.

@andyp1per Thank you for letting me know.

@hwurzburg, you might remember that I aborded this topic in the other thread for the FW
Is there a plan to bring the ESC Telemetry to the AP?

easily added using custom build server

I did that !
Is there a way to confirm the build that I send to the AP has the feature running?
Anyway I am going to build again to double confirm you.

Just double check and the ESC TELEMETRY is NOT WORKING even after building again the custom version. I build the Plane Stable4.4 for the SpeedyBee F405 Wing.
Later I tried building the “latest version” (not the stable) and the compilation fails in the ESC Telemetry :slightly_smiling_face:

Is there any conclusion?

What custom options did you pick?

I’m trying to resolve the same issue. DSHOT telemetry not working on a SpeedyBee F405Wing. I don’t see any ESC Telemetry related options in the Parameters (e.g. OSD1_ESCTEMP_EN does not exist), which led me to believe the ESC Telemetry code is not present in my firmware, which led me to this thread.

Like @Pedro_Claro , I tried to build a custom firmware on 4.4 Stable.

With default options on 4.4 the build completes successfully.

The only ESC-related options I see to enable are in the ESC category which contains PiccoloCAN and Torqeedo Motors. I don’t think that’s what I’m looking for, but I enabled it anyway just for fun. When I enable that, the build fails.

Hi @andyp1per ,
Thanks for your support! Here you are the custom options

I notice the following in the hwdef file → define HAL_WITH_ESC_TELEM 0; is this OK?


I’ts Working Now!!

Basically I enabled the → define HAL_WITH_ESC_TELEM 1, compiled and now its running.
The issue is on the ArduPilot Custom Firmware Builder there is no option to enable this!

Most probably the other APs with 1Mega flash only, may suffer the same issue.

The solution that I used was to manually change the hwdef for the SpeedyBeeF405Wing and going for the local compilation.

Already created a ticket to report this.


1 Like

I did this to address - AP_HAL_ChibiOS: use standard FPV config for SpeedyBeeF405WING by andyp1per · Pull Request #26327 · ArduPilot/ardupilot · GitHub

1 Like