SpeedyBee F405 wing and Yaapu Telemetry thru Crossfire Nano

@yaapu, Has anyone had any luck getting the Yaapu telemetry on the radio from Speedybee F405 wing using Crossfire nano receiver?
I have the receiver hooked up with UART1, serial1 protocol 23, baud rate 57, seria1 option 15, RSSI 3, RC_option 256+1, Crossfire enabled on the radio lua.
I am getting some telemetry data but not all, like GPS

I have - I don’t have this option 15 on the rc
And everything is working fine

Try searching for telemetry sensors on the radio and see what comes up.

On the TX16s radio Yaapu_CRSF_Debug screen, I don’t see any update coming through.
Is UART-1 mapp to Serial-1 or Serial-2 on Speedybee?

My parameters are:
Serial1_Baud_rate = 115
Serial_options = 0
Serial_protocol = 23
RSSI_type = 3
RC_options = 257
RC_protocoal = 1, I tried CRSF only as well

By default, Serial-2 was set to 2, I changed it -1 so is Serial-6

I have the same setup on Matek F765 with CRSF, and it works, but not SpeedyBee.

Any more suggestions?

solved!! I had the Tx and Rx incorrectly pinned :frowning:

1 Like