Speedybee F405 V3 - Frsky R-Xsr - Sport


I am trying to get telemetry from this new F4 board using Sport.
I had it working fine with ELRS 3, but I had to change the radio and I installed a R-xsr.
SBUS is attached to Sbus pad on the board and is working fine. I understand there is no inversion on this board, so I am using the uninverted pad from the receiver and soldered it on T3, which I assume is serial3. I tried changing every parameter possible with no luck…
Does anyone have any hint?
Thank you,

Hi Andre, did you manage to get this resolved? I am also struggling with this board trying to get SPort telemetry working. I haven’t tried the uninverted pad from the R-XSR yet but I have tried using SoftSerial on a couple of pads with no success. I am nervous that the pad on the R-XSR is so small that it might be a bit of a stretch my soldering skills but will try it if it definitely works but I don’t want to attempt it if it is not going to resolve the issue. Many thanks


Hello James! Sorry for the late reply!
No, I did not have any success in getting telemetry to work on the R-XSR with this board. I tried all scenarios possible (SPort, FPort, all available Uarts, soldering direct to the receivers tiny pads…) and nothing. However, if you try ELRS, telemetry works fine. Anyway I gave up on this FC. It becomes unstable when you start enabling simultaneous features like GPS, logging, DShot, etc… I flashed Betaflight back on it and chose a different FC for my project.
I hope this helps you.

Hi Andre, thanks for your reply. I have heard back from Speedybee and they say:

“ We are very sorry, but the F405 V3 hardware does not support SmartPort, nor does it support uninverted SmartPort. The information on our advertisement page is wrong. We will amend it immediately.”

Which is so annoying as it sounds like both of us wasted time trying to resolve an impossible issue. For my build I am using Betaflight and have moved to Crossfire now so don’t need to SmartPort anymore. I am planning on keeping the FC board though as just installed them with the 50a ESC stack in 2 quads. Now that you flashed yours back to Betaflight, has it performed ok? I am having other issues getting the FC board to be able to read the VTX settings. I seem to be going from one issue to the next but I am determined to get the damn thing working as it should :+1:

Yes this is very disappointing as I spent hours working this out.
I did not work on this FC anymore. Besides the problems I had with smartport, GPS and Logging were not working together too, so I decided leave it aside for a while, as it is not reliable. I even trying INAV. Same B.S. Maybe it is meant to be used only with Betaflight. Will work on it in the future, but I won´t be wasting much time on it!
I got my project working the way on a cloned pixhawk… I will use Matek on the next one. I just bought a F405 WMN! Let´s see how this works out!
Tks for your comments!