Servers by jDrones

[Solved?] Quad motors getting HOT in Loiter, but not on bench

pixhawk
arducopter
(Robert Giordano) #1

EDIT: I think I have solved this issue by replacing the Pixhawk with another one, but that doesn’t explain what actually happened. If anyone has any insight, please add to this. Thanks.


I have a new scratch-built quadcopter. With the quad strapped down, I can run all motors and props at mid throttle for 20 minutes and the motors never even get warm. (less than 90F). I have a video of this test, see below.

If I take it outside on a calm day with no wind, and hover in Loiter for 10 minutes, all four motors get so hot I can’t touch them for more than a second (150-165F). I’m hoping someone can shed some light on this issue.

Here are some specs:

  • T-Motor MN3508 380KV motors
  • T-Motor AIR 40A ESCs
  • T-Motor 15x5 CF props
  • Pixhawk 1 running Copter 3.4.6
  • Multistar 8000mAh 6S battery
  • AirbotPower Power Module

Additional Info:

  • props have been balanced
  • vibrations are very low and well within limits
  • ESCs are calibrated (throttle)
  • ESCs are set to the default “intermediate” timing (the only setting for these ESCs)
  • 2500g AUW with battery, camera, gimbal, and all accessories

The ship is designed for endurance. In Loiter with the stick at mid position, it only needs ~20% throttle to hover (or ~14 Amps) so I don’t feel like anything is straining (or should be).

At one point I thought I had found the issue. I’m using custom, 3D-printed motor mounts and the center hole wasn’t quite deep enough so the motor shaft clips were getting caught and sticking. I figured this was surely the cause of my hot motors so I simply used my Dremel and made sure the holes had plenty of clearance. Unfortunately this didn’t seem to have any effect. The motors ran cold for my 20 minute, indoor bench test, then got hot when hovering outside.

I’m at a loss as to what to do next. Any ideas would be greatly appreciated.

Here’s the 20 minute (boring) indoor motor test. The motors never even get warm:

(Justin R) #2

I was having a similar problem because of a bad alt-hold tune. This caused lots of rapid throttle changes in flight which was heating up the motors.

Can you post some logs?

(Robert Giordano) #3

Here’s the log from my most recent flight where the motors were getting hot:

I’m not an expert at interpreting logs so if you can see the same issue you were having, that would be interesting. How did you end up fixing your issue?

I’ve noticed there is an EKF error in this log that doesn’t appear every flight. I’ve also noticed that sometimes my tablet (running the Tower app) says “Compass Not Calibrated” when I connect the battery and try to start up. If I disconnect the battery, wait a few seconds, then plug the battery back in, then it starts fine. It doesn’t always do that either but it did it just before this flight.

Finally, I’d like to mention that a friend of mine has built an almost identical ship (we compared notes, used the same measurements, etc.) and he doesn’t have any of these issues and is doing 35-40 minute flights. We’re using the same size frame, same motors, props, and flight controller. One of the few differences is I’m using T-Motor AIR 40A ESCs and he’s using HobbyWing XRotor 40A ESCs. Both of us have the timing set to “intermediate”.

thanks

(Justin R) #4

Looks like this is because your copter has nasty oscillations on the roll axis

You can see outputs alternating between motors 1+4 (left motors) and 2+3 (right motors)

Have you tuned the quad yourself rather than running autotune? You have some unusual gains.

I would suggest you set the rate roll and pitch PIDs back the original values:

P=0.135
I=0.09
D=0.0036

Then set ATC_RAT_RLL_FILT and ATC_RAT_PIT_FILT to 10Hz, and run an autotune.

More info here: http://ardupilot.org/copter/docs/autotune.html

Justin

(Robert Giordano) #5

Hey, thanks for looking at my log!!

How fast are those oscillations? Are those seconds along the bottom? (42.925015680…etc)

I was using the stock PIDs and I was having the same problem. I will reset them and try autotune again. I’ve tried a number of different PID settings, including the PIDs my friend is using because his quad is almost identical.

One difference between his frame and mine is I have vibration isolating bushings between the “X” part of the frame and the electronics platform that holds the battery/pixhawk/gimbal/etc. I’m wondering if this could be causing the oscillations.

Did redoing your auto tune solve your issues?

thanks again!!

(Justin R) #6

It turns out my issue was completely different from yours.

The oscillations are around 3Hz. I’m not sure what the scale is showing in that graph - it’s not seconds though.

It’s very possible the bushings are the problem if there’s too much movement between the two parts of the frame. I’d suggest you try stiffening it up. (Maybe zip-tie the two halves together in a few places to hold it steady and test again)

If you were having the same problem on the default PIDs, you could try reducing your rate P an I gains (maybe P=0.07, I=0.07).

To avoid damaging your motors/ escs, I’d suggest you do short flights for now, and look at the logs to see if the problem is still there. (RCOU.C1 through RCOU.C4).

This is what you should be seeing:

compared to your current log:

Once you’ve got rid of the oscillations, an autotune would be a good idea.

1 Like
(Robert Giordano) #7

Thanks for the comparison. That was very helpful. I went back and looked at the log from my bench test “Motor Test 2” (the video in my first post) and here is the result:

Since the ship is strapped down and there is no movement between the two parts of the frame, would you say the frame is not the issue and there is some weirdness somewhere else?

(lucamax) #8

The problem IMO is the positon of the battery , since it is not centered on the GC two motors work a lot more .

Need help! Severe shaking on roll axis
(Robert Giordano) #9

The position of the battery would not affect the test on the bench as the entire ship is strapped down. In flight, I used a counterweight to simulate the camera/gimbal and even though it wasn’t perfectly balanced, it would not cause the weird PWM oscillations.

So, my question is, what’s causing the oscillations? I might try swapping flight controllers.

(Robert Giordano) #10

I was hoping to get more insight as to what could be causing the weird PWM oscillations, but just seeing the graphs was good enough.

I replaced the flight controller without changing anything else and it looks like the problem has gone away. Today, I did a test flight in a nearby parking lot, hovering in Loiter between 6 and 10 feet. I landed a couple of times to check the motors and I also checked the motor temps while in the air, using my IR Thermometer. The motor temps didn’t go above 105F.

Here are some screenshots from today’s log:

Please correct me if I’m wrong but this looks fairly normal and is not at all like my previous graph. There were some intermittent wind gusts and I believe the first part of the graph represents this, while the graph from line 120 is when the air was very still. Can someone confirm my analysis?

Here’s the graph of my vibrations. The Pixhawk is attached to the frame with 3M double sided tape. My frame uses vibration dampers between the electronics platform and the motor masts, which are in an “X” shape.

Finally, here’s the log in case anyone wants to compare the two logs:
https://www.dropbox.com/s/xhr1xybqnhi8rel/2017-07-22%2016-36-23.bin?dl=0

So what happened? Was this simply a defective Pixhawk? If so, what was wrong with it? Everything else seemed to work and I couldn’t find any other indications it was bad. The ship DID fly, even if it didn’t fly well and made the motors really hot.

What can we learn here?