[SOLVED]: Prearm Internal Errors 0x800

Hello everyone, does anybody know the solution of the internal error 0x800?

Solution: Take out your I2C connection if gps is connected. I just using the m8n gps and took out the i2c connection. Then reflash your pixhawk as different than your build, after you built your device as different than your device then reflash your device firmware. (I were using rover 4.0.0 and I reflashed the plane 4.0.9 and then reflashed rover firmware again.) While doing that do not connect your i2c connection. Then unplugged your flight controller. Took out its sd card and format it as fat32. Plug your sd card that you formatted as fat32. Then plug your flight controller. Now you can plug i2c cable of gps and calibrate it from the beginning. I solve this problem as I wrote.


Thanks for investigating this. That’s quite odd really but I suspect the issue is also resolved in the upcoming 4.1 release. Thanks for the investigation and sorry for the troubles.


You are welcome Mr.Randy. All we’re eagerly waiting for 4.1 releases. I hope that everything will be good like now.

Hi I have a similar problem I replaced the Se100 with a Neo m9n and are only using the Pixhawk internal mag everything seems fine except error 0x800 how do I overcome this ?

Try my solution which I explained above. I overcome this problem with that method.

Hi, if I do that I guess I will need to re calibrate again

Yes. You are going to start from the beginning.

Ok thanks, will have to give it a go

I have this problem with a brand new H743 board with 4.1beta5 and non-extra sensors. I reflashed with 4.0.7 and back to 4.1beta5 (through). The problem persists. The problem does not appears until I start a motor for the first time after a boot.

The first time that it happen was after I import a full param file from another quad.

I would try the reflash and erase everything and check what happen.

@rmackay9 , would you like some test or partial log before that?


Thanks for posting this because I had the exact same problem trying to build a system and this solved it.

Jeff Berezin

1 Like

Hello Gustavo,
Do you have the resolution of this problem in SITL. Most of the time when I connect my SITL instance, i see this error popup on my hud. I just disconnect and connect again but it is getting frustating and time consuming. Any input on this matter would help.
Kaizar Merchant