[SOLVED] Pixhawk 2.1 Cube Power Problem (Mission Planner)

I’m using Pixhawk 2.1 Cube and 4S7P Lithium Ion power supply.

I’m using 20A fast discharging cells and 14.8V output. (Total 140A 21000mAh).

When I’m connecting the Pixhawk with Missiion Planner with that Battery pack, The cockpit always showing Failsafe error.

The battery voltage and current is showing 0V and 0A.

I have attached the screenshot below.

I want to know the exact reason and solution for this issue.

Thanks in advance…


Can you show us a picture of the wiring between your Power module and Pixhawk. You can also post a log or your .param file.


Sorry, currently I’m out of my Lab. I’ll post the image once I get back there.

I’ll explain my wiring here.

I’m using two set of 2S7P pack in series to get 4S7P output.

The battery is 14.8V, one cell is 6C and total C rate will be approximately 40/45C.

The maximum discharge current of the 4S7P pack is 140A. (I’m using LG HG2)

I’ve attached 10AWG wire to the battery pack and 14AWG for making that series arrangement.

I’m using the Pixhawk 2.1 PDB and connected it to the Power 1 port of pixhawk.

Then from PDB to ESC.

Can you get anything from this?
What are the reasons for this issue?

Are you sure you are selecting the correct battery monitor in Mission Planner? I was having the same issue, even when plugged into MP and the battery, it would show a failsafe and 0v of power

I had to go into the power monitor and play around with selecting different power modules and I finally found the one that worked for me.

Yeah! After selecting the correct PDB in mission planner, the problem got solved.

I’ve attached a Video of doing the same. (Uploaded by someone who faced this issue earlier)