Servers by jDrones

[SOLVED] MAV> link 1 down when attempting to communicate with Raspberry Pi

EDIT: Well it turns out I made a dumb mistake that I glossed over multiple times. I had the TX and RX pins connected to each other, fixing this fixed the issue. I figured I’ll leave this up just in case anyone else does the same thing.

I’m attempting to establish communication between a RPi 3B and Pixhawk 1. I followed the steps from this documentation page:

https://ardupilot.org/dev/docs/raspberry-pi-via-mavlink.html

I followed the manual setup, using ssh to connect to the Pi and setting up the connection using the terminal. When I attempt to run MAVProxy I get the following message “MAV> link 1 down.”

Servers by jDrones