Solved: GPS Blending unhealthy


I had blending enabled on 3.5 and it was working fine for coupple of flights. Now, after a while, when i installed QGC and tested connection, i got message that is on the title.
Any idea what is wrong ? I tested with MP and also and got same message.

Running cube with 3.6 now, still same issue and looks like i dont get any telemetry from gps2 either. Weird, everything was working fine when copter was in use last time, i have not change anything since.

In MP compass 1 and 2 are selected as external. compass 3 disabled.
Both GPS units are here+ ublox.

1 Like

Do you get good sat number and good hdop from both gps?

Whenever i get unhealthy blend it is because gps disagree a lot on the position.


Solved. Thank you for pointing to the right direction.
I had wrong parameters in serial 4 after all, go figureā€¦ :confused:

What were the differences in the params?

Hi. For some reason param ā€œserial4_protocolā€ (gps2) was changed to -1 = none, right setting = 5

Dont understand how that param got changed to none, only thing i did different from the last time when blending was still working (and gps2 active), was that i established a connection with android QGC for the first timeā€¦donĀ“t know if that is any way related to this issue, i doubt that, weird issue but now all good :+1: