[SOLVED]ESC's do not react same to the throttle (skid sterring) stick(sync)


I have finished everything thanks to Mr. David Boulanger, Mr. Dave and Mr. Rmackay9(I’am writing your names in the acknowledgement of my report)

Issue is about ESC’s sync. When i move the throttle up a little bit port motor starts working at a slow speed. starboard doesn’t work. then if i move a little bit further both motors work fine. I have calibrated the radio but I will do it again now.

I have never ever calibrated them. I just plugged them to pixhawk. And there was no such issue. Left shafts dog bone had a friciton issue(choric issue in this boat). Maybe the ESC or pixhawk tried to compensate it? I have succesfully changed the shafts with a ball bearing one that can do reverse(props with nuts original props didn’t have nuts and designed for only forward).

So both shafts work well with no issues.

should i perform an ESC calibration? Or can i simply use trims in Mission planner?

I have no reference guide of the ESC’s but they beep when I arm.

ESCs : https://www.promodelhobby.com/urun/fircali-80a-320a-rc-esc-7-2v-16v-fanli-2s-4s

note: originally the motors had 104 ceramic capacitors, 1 in each terminal. But unfortunately while dissembling the port side motor , I broke one. so the starboard only has 1 capacitor. I couldn’t find any to replace. https://drive.google.com/open?id=1O60edgKxXv6BGzPpXF1K2SVYCZ93HkJz

solution: one motor’s 100nF capacitor was borken I replaced it. so each motor has 2 100nF capacitors. How they do work at the same time. works like a CHARM!

Use a 0.1uF ceramic disc capacitor to replace the lost one. It’s there to reduce commutation arcing causing RF noise. I don’t think that has anything to do with the throttle issue you are reporting. What mode are you testing this in? Is it in the water or on the bench when you test this? Leave the Transmitter trims at zero. You can try ESC calibration but not sure it will do anything. Posting your parameter file might help.


thanks for the reply. Something happened and my radio is unbounded with the receiver. I had to bind it. Then i did a full radio calibration and now motors show 1500 pwm as the default. (thr centered no movement, up fw, down reverse). Now there is a very little difference. One doesn’t move on very little speeds. testing on my bench. I dont think it will create a big impact.

I’ll try to find that capacitor. There was a 150pwm difference when i checked the servo outs on the mission planner. now they are equal.

another issue, gimbal servos stopped working. I don’t why but they just don’t work. :frowning:
It used to work with the same connections and wiring .

I want to ask a quick question about EMF.

I have changed the position of GPS module. It was inside the hull, in front of the pixhawk. but just beneath the pix hawk there is the power module(back of the plywood).

So i thought moving the GPS on top of the hull is a better idea, and it is in the air so maybe better connection is viable.

I have one question.

Should i apply aluminum foil for shielding (on top of the interior hull and half of the cockpit. would it work?


last version.param (13.4 KB)

Here some telemetry logs.

EKF of compass goes very high some times. even to boat doesnt move, gps locations tells something else? is it becuase of the vibration or the EMF?
some telemetry logs on my test drive

Tlogs don’t have the value of Dataflash logs for troubleshooting purposes. Post a .bin file

I see from the parameter file that you have disabled the external compass (compass 1). Why?
Also the Cruise Speed (1.5 m/s) at Cruise throttle (50%) looks suspect. Did you calibrate this? It’s really not optional:

On 2nd thought maybe you did perform this and all that lead ballast (batteries) slows the boat down.

That could be accurate. My boat moves at 1.25 M/S at about 45% throttle. These small displacement hulls are comfortable running at about 2 knots. Any faster and amp draw starts to climb a lot and the boat just starts pushing water out of the way instead of cutting through it.

Hello. I wanted to turn of the Pixhawk’s internal compass.
I never did test PID tunings, I just copy pasted mr David’s values. Since my boat is 92cm and around 5kg with dual thrust(36mm 3 blade props).

https://drive.google.com/open?id=1W6bO7pWTnTP9kY0nUFN3YGedVw7mxCJA bin files of that day extracted from sd card.

Do i need to really adjust cruise speed and throttle? ı didnt calibrate it? is it why the gps drift happens even tho device is stable with 10 satelifht and 0.9 hdop?

I dont think I comprehended how to perform a nice mag and compass calibration. I guess i need to turn on both ESC’s and even Odroid so that the calibration will count the EMF?

Is the idea of putting aluminum foil on the top of hull (interior) so irrelevant?
My pixhawk is fixed with 2 pieces of 3M’s 250 muhsroom velcros and I think it allows for little movement. I think i will use plastic tape to fix it.

I’am afraid to re-do the Mag and Acell calibrations as i am afraid to fail them? I have few hours left :frowning:

my pool is 15 meter x 15 meter. And I want to be able to run the auto mode well in that small pool. but as you see in the Telemetry log there is EKF error and gps is dritfting :frowning: I had no idea it would be this hard :frowning:

and without your helps I would not even come this far by any chance :frowning: on the summer if i can graduate the college now I want to begin exploring deeper since ill have tons of free time. I’ll test out every method and will make you tube videos and guides here and pledge to help if i can manage to understand things better. I even want to begin coding in C++ to add features to the arduboat such as AIS collision avoidance and so an on.

I just hope that i made the mistakes in PID(btw my pid values were different while i was testing so that bin and telemetry logs have my older parameters) which causes wrong readings thus causing GPS drift and making my auto boat failing. :frowning:

I can not express my gratitude towards you fellas and my immediate help. :frowning:

maybe i didn’t enable some Kalman filter settings? it cant be a simple vibration issue because when the boat is in stationry mode with more than 7 sats and 0.8-0.9 hdop it still drifts. Its either poor mag or accel calibration :frowning: :frowning: :frowning:

or the EMF destroys everything. with odroid i still have the gps drift. as seen in pictures I moved it upside to the boat for more distance from motors and power module.

pixhawk is moundted on plywood. under the wood on the other side there is the power module. maybe i should use tape and foil and apply it under the pixhawk?
I only have this generic tape for EMF and aluminum foil.

(gray tape https://urun.n11.com/bantlar-ve-kesiciler/dayanikli-guclu-yapistirici-bant-gri-bant-48-mm-25-metre-kuvetli-P312444633?gclid=CjwKCAjwiN_mBRBBEiwA9N-e_pFR-PmBcigp6fMMId_cIrwrWFJrfsqb1q-UBtMv4AtT6K-xvpKd2BoC5vsQAvD_BwE&gclsrc=aw.ds)

I’m trying to digest what you just wrote. Cruise speed and throttle being adjusted properly will just keep the motors from oscillating a lot I think. GPS drift is most likely because your moving very slow and a little drift affects thing more. At least this has been my experience. I’ll look at your logs later. You really should not have to do anything more than the standard compass calibration plus IMU calibration to make the boat work. If your try to make an auto mission in a 15 X 15 meter pool with a waypoint radius of a few meters you will have some problems. And I don’t know what the landscape is around that pool. Vibrations on my boat have not been an issue and it is attach to the boat with nothing more than Velcro.

thanks for the reply. bad news. I was naive enough to use the 16gb sd card comes with the pixhawk. bin files just dont work. I’m mourning at my idiocy. :frowning: :frowning:
It is probably a 100MB card :frowning: Ahh my heart aches. I’m too naive. I’ll not sleep to night(its midnight here lol). my telemetries work fine since they are on my pc.

I ll buy a nice card. I can’t believe this. experience is gold really…

I believe there is a great deal of EMF wrecking up my GPS compass.

I think our boats are some what a like(my props are probably way smaller than yours tho) and the PID values will work fine.

I could’nt find the 104 ceramic cap. one motor is missing one (it has 1 cap). I will use aluminum then as i believe it will somewhat mitigate the gps interference. I’ll conduct a test in the morning.

Do you think i should re do the calibrations?

I use compass 2 enabled as the primary and only compass(I think it is the external compass)

Any ideas on the EMF theory?

External compass is usually compass one. Once I look at your .bin log I would have more advice. I have a stock 4gb card in my pixhawk and it works fine. You may have to move your GPS/Compass to a better place maybe but I don’t know at the moment.

I was mistaken. I will change it to 1 then.
my bin files didnt work on my MP. :frowning: probably because of the faulty fake chinese sd card. I’ll get a new one. it was stock and probs it was not 16GB but 100mb :frowning:

I changed the compass as Mr. Dave suggested. There is way less drift how ever i see that i need a calibration because it points in a wrong direction. on the EFK status menu the Velocity keeps jumping and every 30 seconds the compass jumps to full red then almost zero. I’ll test the alumunium foil now

Right, you turned off the external compass not the internal compass. Compass 1 should be active and compass 2 disabled. You need to fix the direction issue. 1st set the Compass_Auto_ROT to 2 and perform another compass calibration. Aluminum foil won’t do anything just perform a proper compass calibration. This requires that you rotate the boat around in several axis preferably under battery power. Are those giant batteries secure enough to do this?

And there is something wrong with those logs.

Calibrate the compass. It’s important. It does suck when your boat is 20 pounds though.:slight_smile:

yes. related with the fake sd card :frowning:

batteries are fine (veltrco holds tight)

it fails at 33 percent all the time :frowning:

:open_mouth: omg mine is only 5 kgs and still hard to do it

since it is stuck at 33 percent i copied and pasted the 2nd compass in the parameters now it looks in the right direction

I’m not so sure that is the proper thing to do.

I know right. It fails at 33 percent… :frowning:

I did change the compass_off to even 3000. still fails. Maybe i should not try it on my balcony yet it is in open air